HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
bobdea

rear hub looseness

3 posts in this topic

my 426 has a ton of play in the rear, think it's a bering?

it looks like it's loose between the axle and the hub, how much is normal with these bikes?

this is one thing I've never dealt with, the only thing I have to compare it with is my KLX which has none

Share this post


Link to post
Share on other sites
my 426 has a ton of play in the rear, think it's a bering?

it looks like it's loose between the axle and the hub, how much is normal with these bikes?

this is one thing I've never dealt with, the only thing I have to compare it with is my KLX which has none

There should be no play. You have blown out the bearing.

Doesn't it handle funny with all that play?

Share this post


Link to post
Share on other sites

yes, until tonight I was blaming the handling on the bald ass tire I'm runnin'

good to know that my first though was probably correct!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0