Dynatek ignition for TPS stutter?

It comes with 4 preset curves, and I'm not sure if any of them get rid of the studder. That's why I was trying to ask ThumperBloke up there if he made his own maps to get rid of the studder, or if the preset curves got rid of it. Still waiting on an answer. :worthy:

cmon bloke, get awn it ! I wanna know.

William, all

Please appreciate that I’m not trying to be clever or anything, just trying to help those that aren’t happy with their WR450s.

OK, so JD has posted some graphs, they are very clear, and he is obviously a highly respected expert.

But, who is to say that another ignition box is the only solution? The very fact that hardly anyone has actually paid out for a new box proves the fact that few are 100% convinced! Why is not everyone doing it???

There is on this very thread someone who has changed the box, and is saying it hasn’t cured the stutter, but is reprogramming it to do that.

<ALARM>!! - is backing off the ignition timing just masking another problem, like pulling the TPS does??

Yes, the UK CDI is different – the number stamped on the unit plus the manual back this up 5TJ-CO is the UK one, and the US is 5TJ-BO

This is a clear fact (good), but no-one knows why or what the differences actually are – we cannot just assume.

There is more than one US bike that has been rejetted and fixed. We need more facts before drawing a clear conclusion. I have offered one solution, if it doesn’t work on US bikes fair enough, but is worth trying surely?

- Steve

Some quotes:

Jetted my bike on the dyno, still had about 20% of the stutter still there.

Bought a Vortex CDI. On the default setting stutter still there, on map 7 i think, stutter gone all together!

So you can still stutter with a Vortex.

The latest update:

Got the bike out for a 20 mile ride the other day - and it is awesome :worthy: The Vortex CDI solved the problem for all practical purposes. Just like the dyno graphs show, there may still be a stutter, but it is so small that I can't feel it (and I am very picky about this particular symptom). It is a night and day type of comparison....and with the handlebar mounted map selector switch it becomes very obvious. I switched back to map 1 while riding in the rpm / throttle range where the symptoms were the most pronounced before - and immediately the stutter was back, as strong as ever - then flip the switch to map 7 and it disappears

.

And again. Is this not suggesting the masking of another issue??

I know for sure, at least James Dean and I have explored every jetting combination in pursuit of a solution. I run an O2 sensor on the header with an on-board data logger. My equipment is not as nice as James but I ended with the same results. Many do not complain for a couple of reasons.

1) They never ride on road, they are always in the woods, either constantly working the throttle or running flat out across the desert. The stutter appears at a steady mid throttle, the sort of thing you experience driving on the road.

2) Many riders, simply put, do not realize it is not running as good as it could. I have worked on many bikes for people. Guy comes in with one issue, I resolve it and test ride the bike, discover the bike runs like crap. I ask the owner "Has it always been like that?" Invariably, I get the response "Yup, has since new, the dealer said they all do that....". I re-jet and tweak. The owners are simply amazed. Unfortunately, the "WR stutter" cannot be 'jetted away'.

The different CDI's are not backing off the timing. It is felt that the stock CDI is jumping between different maps (Low RPM and High RPM). Basically, the bike is in the low map, rpms increase slightly, the bike switches to the high map, mis-fires due to the timing of the event, rpms drop, engine reverts to the low map, rpms build, switch to the high map, mis-fires due to event timing and then reverts back to the low map. Over and over, hence the stutter. It is a combination of throttle position and RPM. A box with a different map or logic will not behave the same.

I made a custom map, using the dynatek software. The curve works great on my bike, with my combination. I have a stock 2004 with the stock muffler endcap removed. My jetting is excellent from 700ft to 6000ft.

I can email the custom curve to Dynatek and let them know it should be supplied as one of their 4-curves.

Great Thank you!

But did the 4 stock maps that came with it have the stutter ?

Great Thank you!

But did the 4 stock maps that came with it have the stutter ?

No, i made a custom curve. But maybe they will update the curves with mine. Since all the WR450's have this problem, maybe one of their curves should address this. Let me email mine to them and see what they say.

So you got the cdi ran it , it had no stutter then you made your own better map ?

You are funny, Extractor. I don't know how to make this any more clear.

My Wr450 has the studder, no matter what jetting.

I now have a Dynatek CDI.

I made my own map to eliminate the studder.

I have emailed the map to Dynatek, hopefully they will respond soon.

So tell us about the performance gains??? Is it worth the coin? -=-- Does it give a punch like adding a slip-on? or a new tire? How would you rate it so far?

Yes, the Dynatek ignition is really simple to install. I noticed instant starting and throttle feels more crisp. Its a good mod, for sure. Getting rid of the studder during cruising-state low throttle settings is very nice. Also, one of my favorite features is the Datarecording. Records how many starts, hours, WOT time, max rev's, etc.

I TPS 'emulator' concept is being experimented here.

can't wait!

William, can you move your posts to a new thread? since this was about the Dynatek CDI curing the studder.

I understand but I cannot do that. A Moderator has to. I'll make a request though. :worthy:

I understand but I cannot do that. A Moderator has to. I'll make a request though. :worthy:

Moved.

Man if all I have to do is some wiring and resistors with minor performance loss thats the way it will stay.

I’m still hearing the need to change the timing, be it a custom map or TPS – something is not right here as you are simply detuning the engine to stop the stutter?

Good luck, I’ll leave you guys to it – I genuinely hope you find a cure.

Steve

I’m still hearing the need to change the timing, be it a custom map or TPS – something is not right here as you are simply detuning the engine to stop the stutter?

Good luck, I’ll leave you guys to it – I genuinely hope you find a cure.

Steve

No, not de-tuning, correcting an anomaly between the TPS and the CDI. If you can keep the CDI from 'jumping' back and forth from one map to another, you have removed the stutter, because that IS the stutter. So, you can pick one or the other, with the switch, by telling the CDI the throttle is no longer in that mid-point sending out a specific voltage that is confusing the CDI. If you find voltages that work perfectly for each map, and you make sure the CDI only sees one or the other, not the 'almost/maybe' voltage that is causing the stutter, you have eliminated it.

Have I got that right William1?

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now