HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
ReedRulz

2007 YZ450F rekluse

7 posts in this topic

Can anyone give any advice on how I should set the rekluse pro up? I used the recomended settings and the clutch engages as soon as you touch the gas it feels like it drags a little while idling. My bike idle is about 1700 RPMs. I just put it in today and only rode for a few minutes will it work better after it breaks in or should I try to adjust to engage at a higher RPM?

Share this post


Link to post
Share on other sites

I use all the stock balls and the medium spring. I am riding an 05 and weigh 245 with gear.

I like this setup, it engages quickly when I want, but has a LITTlE slip when needed. I am using Rotella 'dino oil' if it makes any difference.

Share this post


Link to post
Share on other sites

I have mine set up with all the balls and medium hard also. I use it for MX and woods though, so I wanted it too hook up fast. Mine hasn't changed much since break in, so if your looking for a different hook up I would say use the chart and fine tune.

Mine also moved a small amount when I set the idle at 1800. I backed it down to 1500 and that went away. No stalling isssues at 1500 either.

Just keep playing with the settings and springs until you get what you are lookling for. I won't own another bike without a Rekluse now, I love it.

Share this post


Link to post
Share on other sites

I run mine minus 3 balls on med/soft. Engages just like it would if I did it manually. The drag is always a bit more until you break it in. You can also turn down your idle just a hair. If its lurching just a tad then its setup pretty good though. Long as its not stalling your set.

What oil you running? They recommend Rotella. I use Amsoil syn with great results.

Share this post


Link to post
Share on other sites
I run mine minus 3 balls on med/soft. Engages just like it would if I did it manually. The drag is always a bit more until you break it in. You can also turn down your idle just a hair. If its lurching just a tad then its setup pretty good though. Long as its not stalling your set.

What oil you running? They recommend Rotella. I use Amsoil syn with great results.

Im running Rotella in it now but as soon as I run out im running amsoil

Share this post


Link to post
Share on other sites
Im running Rotella in it now but as soon as I run out im running amsoil

You should be good to go then. Give it some break in time.

I have mine set to engage just after idle. You can turn down your idle just a bit if its partially engaging after break in and you should still be ok.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0