Trail tech stator & Moose Wiring

Hello,

I have a trail tech lighting stator and a moose racing harness with regulator. I

I am having trouble powering my lights, perhaps I am not connecting correctly. I am using a Moose Racing wiring harness [2120-0001]. I am confused about how to connect to the Regulator. The harness has a white and yellow wire that is supposed to connect to the stator. The stator has 2 yellow wires coming out of it. The yellow wire (from harness) is connected to all the lights (power) and is labeled "Yellow-Stator"- and the white is labeled as "kill", however, there is also a kill switch that is interconnected in the harness and is functional. I am not sure if I am supposed to connect this white wire to the other yellow wire of the lighting stator?

:worthy:

Thanks in advance.

I already did. Trail tech wont help. Also, Moose Racing doesn't support their products. They have no tech support at all or even a phone number.

Anyways, does anyone know where the output of the stator connects to?

well, it is time to get a voltmeter and find out which wires are which on your moose harness.

Download a wiring diagram from trail tech also.

I have a trail tech system and it works flawlessly

I am pretty positive about which wires are which on the Moose harness, I am just not sure which output from the stator connects to what on the harness. I imagine most systems are very similar...

Does the output from the stator connect to the regulator/rectifier?

Anybody?

:worthy:

Sounds like a good reason to not buy anything from Moose, to me....Sorry.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now