HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
UPSWR450

Drain Plug Problem

3 posts in this topic

I went to change the oil in my 07 Wr450, i got the filter changed drained from both plugs. I put the rear plug back in no problem then the front plug i put in finger tight first the go to put the wrench on it and it stripped the !@#$%^&ing threads out of the hole. Whats the best way to fix this i want to ride this weekend.

Share this post


Link to post
Share on other sites

I haven't had it happen but you might have to drill it out and retap it and get a different plug and gasket.

Share this post


Link to post
Share on other sites

I don't know if the 450 is any different than my 426. May people suggest heli-coils, but they might not be the best way to go (see this post). Tapping it out for a larger bolt would be easiest if you have the sidewall room.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0