HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
abou_l_simm

Has anyone tried this?

14 posts in this topic

Are you sure it works on the '06+ YZ's? How many watts are they claiming their stator produces?

Share this post


Link to post
Share on other sites

It will be the same Electrex POJ stator everyone else has tried to use. 55w AC, 35w DC, 3-7 hours run time before the stator fails.

Share this post


Link to post
Share on other sites

He did say the stator output is 50w, I asked him specifically if this was an Electrex or Moose stator and he still didn't answer me.

I'll update when I get an answer.

Share this post


Link to post
Share on other sites
It will be the same Electrex POJ stator everyone else has tried to use. 55w AC, 35w DC, 3-7 hours run time before the stator fails.

Not cool :crazy:

Share this post


Link to post
Share on other sites
Not cool :crazy:
What's not cool? The fact that there exists an unreliable product for which people pay too much money, or saying so?

Share this post


Link to post
Share on other sites
What's not cool? The fact that there exists an unreliable product for which people pay too much money, or saying so?

Umm...it's obvious he's saying the product is not cool.

Share this post


Link to post
Share on other sites
What's not cool? The fact that there exists an unreliable product for which people pay too much money, or saying so?

Product not cool, I trust you Grayracer, I have been here for a while and read lots of your posts.

Share this post


Link to post
Share on other sites

To expand on the issue a little, there is apparently, based in large part on reports posted here, only one stator being made for the '06+ YZ450 that has lighting coils, although it is marketed under several names. Under any name, it has received less than favorable reviews regarding reliability. If you buy one, shop based on who will stand behind it best, and not just the part, but the collateral damage as well. At least one member lost a CDI when one of these jewels went bad.

If there is anything factually incorrect about the above, someone with good info please step up and post it.

Share this post


Link to post
Share on other sites

Nick at Proracing specifically stated that their stator is not Electrex /Moose/Electrosport. But their FWs are. But who knows. I have both a Moose and a Proracing. Time will tell if they fail but for now I plan to carry a spare ignition cover with a stator in it ready to swap out by the side of the road if need be. Pathetic, but reality. If I do have a failure, I will split the cases and put in the WR set up.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0