Bog after landing on 2006 YZ 450

Whenever I do a large jump and land I get a wierd bog when I get back on the gas. Anyone had this? Messed with the fuel screw a little but no luck.

Pilot 48

Main 170

Whenever I do a large jump and land I get a wierd bog when I get back on the gas. Anyone had this? Messed with the fuel screw a little but no luck.

find the jetting spec thread and see if you are off at all.

there are 3 remedies, some that people agree with. some that people debate.

easiest for non tech types is pay to play. send your carb out to Zip Ty. Tokyo Mods etc.

then there is the self jet method and adding a Quickshot (people claim this product is BS but it is for your exact scenerio...)

JD Jetting offers a complete kit as well.

also check the jetting specs from your exhaust MFG if it's aftermarket.

:excuseme:

Check two things:

  • Your float level
  • The carb isolator/mount sleeve

Occasionally the carb will tilt down an rearward violently when landing, and can actually become disconnected altogether if the sleeve is shrunk and not holding as intended. If it's weak, replace it. Don't modify the clamp to make it tighter.

Ask Chad Reed:lol:

How does it run otherwise? Check the Jetting Link on the site, seems jetted rich, but it may be fine for your area.

Check the carb went tubes to make sure they are not plugged with dirt. I have had this cause a bog on landing on multiple bikes. WD

I would tend to go with Gray. Sounds like a float level issue.....Fuel sloshing around after landing creating a rich mixture.......

Defiantly check the float level....

Actually, I was thinking low float level, but whatever...

:smirk::excuseme:

I'll check it out tonight as I am putting a JD jet kit in as well. I will report back.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now