Lighting Stator

I see there is a lighting stator offered by Moose (which is apparently the same as the ElectroSport) for the '06 and '07 YZ450F. Does anyone know if Yamaha changed the stator on the '08/'09 models? Wondering if the Moose stator will work on an '09.

I believe there is a difference in the number of bolts used to anchor the stator to the case. The '08 uses one extra compared with the '06-7.

I figured there must be a difference. :banghead:

I wonder if it would work with a little "modification". :banghead:

Actually as long as three out of the four bolt holes line up, you should be just fine. You would think if yamaha was going to secure the stator with one more anchor point, that they wouldn't go to all the trouble to to redesign the whole mounting configuration, but just add one more boss on the case for an additional bolt. If your local dealer is cool, just order the stator, and when it comes in, take your ignition cover there to the dealer and see if it will fit - that way if it doesn't fit they'll be much more inclined to send it back (and refund your money)if you don't take it home.

well, i can tell you pretty much 100% now that it will work - i just received a replacement stock stator for my 07, and it has 4 mounting tabs - so therefore the stators now are all interchangable from 06 and up. the moose stator in your bike will just use 3 of the 4 available mounts - no biggie.

good luck.... i put one on my bike last week made it 2 miles and it lost spark.

just took it back to the dealer sat to be sent out for a replacement.

yea, i put a brand new moose stator and a stock cdi back in my bike a week ago - started up, idled and ran great, blipping the throttle for about one minute - then dead!!!!

I'm going back to an all stock electrical sytem and just run my lights strictly from a battery!

Me too! The first electrex stator lasted about 10min then no spark. The second one worked fine. I have a trail tech 100w on my 08yz that has been working for about 6mths. If anyone wants my electrex stator pm me with a offer.

gdbarr, TT makes a 100w system for the YZF quad. Is that what you are referring to?

gdbarr1976 changed the left end of his crank to a WR part and purchased a WR outer case so he could run the WR/YFZ flywheel stator. It will not fit a YZ450 without these mods.

gdbarr1976 changed the left end of his crank to a WR part and purchased a WR outer case so he could run the WR/YFZ flywheel stator. It will not fit a YZ450 without these mods.

Got it. Thx. If I ever pull the motor then I might also make this mod. Maybe WR gearing too.

gdbarr, TT makes a 100w system for the YZF quad. Is that what you are referring to?

No. I put a trail tech wr stator on my yz. It was not easy. WR crank end, flywheel, side cover wiring harnes and cdi. Not easy, but it can be done.

GD,

While we have your attention, how is the performance of the YZ engine affected by the use of the WR CDI?

GD,

While we have your attention, how is the performance of the YZ engine affected by the use of the WR CDI?

I really cannot tell any difference once it is running. What is strange is it starts easier. It my be due to more flywheel, allthought I had some weight on the old flywheel or it may be that the mapping curve with the wr cdi is set to alter the spark at idle to make it easier for the electric start to turn it over. Not sure but it really starts easy and it seems to be less stall prone. Again that may be ignition or flywheel or both. Once it is running I really can't tell a difference in the performance at any level. It has been 100% reliable and if someone really wants 100watts of power for some serious lights on a late model yz it does work and I think is the only way to do it. The reason I went to the trouble was I was planning on doing the Baja 1000 last November. I did the 500 on my 06 yz450 and it worked great. I broke my collarbone 1 week before the 1000 last year so I had to put it off till this year. Can't wait!!

The starting is probably mostly a result of increased spark strength due to increased primary side current at cranking speeds. The extra weight, and possibly the base timing, certainly contribute.

I wondered mostly about torque through the low and mid range related to the advance curve. Sounds like it worked out.:excuseme:

For the guys who are having issues with the Moose/Electrosport stator what year YZF do you have? I know we were having issues with the ESL380 stator which fits the 400,426, 01-08 YZ250F and the 03-05 YZ450F. Or is it the ESL387 which fits the aluminum frame 450F.

To be completely honest we are aware that there are issues with the source coil burning up on the ESL380 stator and our R&D department is currently taking a look at this stator.

Trent Kirby

Technical Sales Representative

Electrosport Industries

3803 Oceanic Dr Suite 201

Oceanside Ca 92056

760-842-8300 x1

760-842-8306 fax

www.Electrosport.com

doe's any one know if you add a battery to your 06 and newer yz450 with an r/r and not run a light in the day will it charge you battery

The failures discussed here have to do with the aluminum framed, second generation models, from '06+.

doe's any one know if you add a battery to your 06 and newer yz450 with an r/r and not run a light in the day will it charge you battery
"r/r"?
"r/r"?

Regulator/Rectifier?

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now