HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
chaseboka

clutch or transmisssion problems?

3 posts in this topic

I was ridin my 05 wr450 around in the mud. i stopped and my bike smelled really hot but i didnt think anything of it, so we sat there for a bit and i started it up and tryed to go but it wouldnt move. would that be my clutch or transmission? thanks :p

Share this post


Link to post
Share on other sites

If the motor revs but won't go anywhere then its the clutch, if the motor won't rev then you got something locked up. Sounds like you burnt the clutch up considering you smelled something.

Share this post


Link to post
Share on other sites

you sure your tire wasnt in the mud still? :p

maddog is correct if it rund and dont move its the clutch. or the little ball popped out

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0