yz450 2009 giving me engine problems

hi guys i would like some help with my 09 450 ive been having some running problems with it its is hard to start and when i do get it going it will cut out straight away it stalles very often and its missing and it has been just cutting out wile riding i dont meen stalling i meen cutting out like in 3rd gear with a fare bit of revs. if i was a fast rider i would under stand some were and tare on the engine but i am just a novice at best.can anyone help??????????also i havent changed anything to do with the jetting or anything as like i sed i am just a novice and am unsure as to what i am doing so the bike it totaly standerd

hi guys i would like some help with my 09 450 ive been having some running problems with it its is hard to start and when i do get it going it will cut out straight away it stalles very often and its missing and it has been just cutting out wile riding i dont meen stalling i meen cutting out like in 3rd gear with a fare bit of revs. if i was a fast rider i would under stand some were and tare on the engine but i am just a novice at best.can anyone help??????????also i havent changed anything to do with the jetting or anything as like i sed i am just a novice and am unsure as to what i am doing so the bike it totaly standerd

Wow, that was a bit hard to read, try writing a little clearer. Anyway, sounds like you got a dirty carb. I know the bike is new, but it could have had gas sitting in the carb for weeks. Try cleaning the carb and all it's jets/passages. If you can't do it, take it to a reputable shop where they can clean it. How long is the warranty period in the UK? You might still be under warranty from Yamaha, check with your dealer.

It could just be a jetting problem. I bought a new 08 about a month ago and had to move the needle down to get it to run better. It was rich in the mid-range brand new. Runs better now but still not 100%. I have a slip on coming and want to see how it runs with that before pulling the carb again.

it could be a jetting issue, or a possibly a floatbowl level issue

or it is a TPS or CDI issue

Did the bike always run like this since you bought it?

If it is new and jetted correctly I would get the CDI and TPS setting tested by a dealer -

Hey..What kind of slip on did you order?

if the bike is warmed up hold the hot start when you start the bike. and I know what you mean about it stalling all the time but I have only noticed it when I chop the throttle. it shouldnt be stalling if you are high on the revs, sounds as if there is some dirt in the carb.

I have rejetted mine and will be getting a heaver flywheel to solve the stalling problem.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now