Sign in to follow this  
Followers 0
Yamafun

Rekluse clutch great, but...??

9 posts in this topic

Hey guys, I just installed the Rekluse pro clutch on my '06 WR450. It seems to be doing great, but now I have a lot of 'decel popping' going on. It has all the stock jetting/exhaust on the bike - (even though I have the JD kit, just never installed it). I'm wondering if changing the clutch could have anything to do with jetting..??? And if not, why would I have so much engine popping now? Any ideas?

Share this post


Link to post
Share on other sites
Hey guys, I just installed the Rekluse pro clutch on my '06 WR450. It seems to be doing great, but now I have a lot of 'decel popping' going on. It has all the stock jetting/exhaust on the bike - (even though I have the JD kit, just never installed it). I'm wondering if changing the clutch could have anything to do with jetting..??? And if not, why would I have so much engine popping now? Any ideas?

My guess:

You no longer have engine braking , so the carb vacuum has changed.

Share this post


Link to post
Share on other sites

It is not the Rekluse making your bike pop on decel. Your jetting is too lean. Richen up your fuel screw. If you have to go past 2 1/2 turns out, then you need to go up to the next size pilot jet.

Share this post


Link to post
Share on other sites

The only time that you lose engine braking with a Rekluse is when you lock up the rear brake. A quick blip of the throttle will re-engage the Rekluse, restoring your engine braking.

Popping on decel is typically an exhaust leak. I just went through that on my WR450. I hadn't replaced the header gasket/donut when I changed headers. A new gasket and some high-temp rtv silicone between the header and muffler cured my popping.

Share this post


Link to post
Share on other sites

I installed a rekluse z-start on my 08 WR450 and have a few questions. After you installed the clutch does the clutch actuator arm move freely? Mine moves around like there isn't any friction. Is this common? I then tried to install a rekluse clutch perch adjuster and after installation there isn't any play in the clutch cause the cable is too tight. I ordered a new cable but is this the right fix. Any advece will be a great help! Thanks

Share this post


Link to post
Share on other sites

I put in a Z-start pro in my 07 WR450 and am not noticing anything adverse. I had a regular z-start in my DRZ400 and ended up putting in a perch adjuster, I did not have to install a longer cable though.

I would give rekluse a call they are very helpful and worked me through an issue with my original z-start.

The pro was worth every extra penny in my opinion. I know that does you no good now.

Good luck. Feel free to PM me if you need any help.

Share this post


Link to post
Share on other sites

I'll call them tomorrow when they're open. Hopefully I can get this straightened out. On the 07 WR450 they have a cable upgrade for it but nothing for the 08. I think the instructions weren't updated and it left that part out. Thanks for your help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0