Sign in to follow this  
Followers 0
tarlint

bike dies when bars are turned hard right....

11 posts in this topic

2000 WR 400 runs great. When at idle, if you turn the bars to the right, at a given point the bike starts to die.......if you turn them all the way, it dies immediately.

I tried changing the kill switch out thinking it was shorting.......still does it. Anyone have any ideas???? I am a fairly new rider with minimal experience troubleshooting this stuff.

Thanks in advance for reading and helping.

Share this post


Link to post
Share on other sites
2000 WR 400 runs great. When at idle, if you turn the bars to the right, at a given point the bike starts to die.......if you turn them all the way, it dies immediately.

I tried changing the kill switch out thinking it was shorting.......still does it. Anyone have any ideas???? I am a fairly new rider with minimal experience troubleshooting this stuff.

Thanks in advance for reading and helping.

I would look at the manual and take of the headlight off and check the wiring. Check your throttle cable too.

Share this post


Link to post
Share on other sites

should i just move it to the right and try and loosen the cable.....or do I actually twist the cable harness to loosen that part?

Share this post


Link to post
Share on other sites
Got to be cable or wire being pinched

:)

Check that nothing is being stretched ie throttle cable. After I had a fall once on another bike the throttle cables rotated round slighly & started to cut out on full lock.

Share this post


Link to post
Share on other sites

Yes, move it a little to the right. As you turn right it is opening the decompression release and the engine will die.

Good luck.

Share this post


Link to post
Share on other sites

yep, had that one too...i thought it was the kill switch too

mine did it after i fitted new bars with raisers...decomp lever just getting tension, enough to open it a bit

good luck

Share this post


Link to post
Share on other sites
yep, had that one too...i thought it was the kill switch too

mine did it after i fitted new bars with raisers...decomp lever just getting tension, enough to open it a bit

good luck

Add me to the tight decomp club, an easy fix though.

Share this post


Link to post
Share on other sites

I seem to recall the same problem on my 650 right after I put taller bars on. I ended up loosening everything up and moving the kill switch, clutch lever /decomp inboard just a bit and it went away. Never could determine which it was, but same deal right hand turns only going real slow where you really crank the bars over.

Share this post


Link to post
Share on other sites

Had the same problem some time back on my '01 WR400, decomp cable misrouted, turning the bars activated the decomp.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0