Sign in to follow this  
Followers 0
JonBrewer1981

1999 Yz 400 ??

6 posts in this topic

I just got my first four stroke, it's a 1999 YZ 400, It runs good but backfires and the header pipe glows red sometimes and the bike doesn’t want to idle , I was just wondering if this is normal? It has an fmf power bomb header with the fmf power core 4 muffler. When you’re riding the bike it seems to run good, just backfires and doesn’t want to idle and the header pipe was glowing red. Any info you can give me would be great, Thanks.

Share this post


Link to post
Share on other sites

If you let the engine run at a standstill for more than about one minute, the header will glow. Normal.

If you let it run about 30 seconds longer than that (maybe more), it will push coolant out of the radiators. Also normal.

Raise the idle speed a little and adjust the mixture:

http://www.thumperfaq.com/jetting.htm#PJ

Download a manual:

http://www.yamahaownershandbook.com.au/?r=0

Share this post


Link to post
Share on other sites

backfire is a sign of running lean, try getting 1 size bigger main jet or move your needle up one

Share this post


Link to post
Share on other sites
try getting 1 size bigger main jet or move your needle up one

Neither of these has anything to do with decel backfire.

Share this post


Link to post
Share on other sites
backfire is a sign of running lean, try getting 1 size bigger main jet or move your needle up one

It can also be a sign of running rich...but check the easy stuff first...is the gasket at the header to midpipe joint in good shape and is the clamp tight?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0