HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
TyeeHusky

Elctrical problem question

3 posts in this topic

Anyone ever encountered or wondered what they would do if the 07/08/09 WR odometer would not power up?

I have been on the trail before and before pushing the power on button hoped that it worked. If it did not work does anyone know of a way to jump around the odometer so you can start the bike?

Hope it never happens but without power to the odometer the bike will not start.

Thanks in advance

Share this post


Link to post
Share on other sites

Who has ever been out in the middle of the mountains and wondered what they would do if the odometer would not power up.

Share this post


Link to post
Share on other sites

Sounds like the power switch is having issues.

The bike will run fine without the odo, it is reflecting a lack of power being sent by the bikes on/off switch. When the odo is out, is your taillight out (another confirm) too?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0