HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
WRtaz

wr450 2007 coolant leak

17 posts in this topic

Over the past few weeks when I started the bike I noticed some coolant dripping from under the bike. I just traced it down to under the water pump. There seems to be a small hole under the pump where it's coming from. This is a manufactured hole not from damage. I checked all the bolts so they're all good.

It seems to happen if it has a hard time starting, I think it stops after that. Is this normal or something to be concern about? The radiator is full to the top but the reserve was a bit low. I just added a bit.

Share this post


Link to post
Share on other sites

That's the weep hole and usually means that the waterpump seals are bad. Same thing on my 07 WR450. Pretty easy fix and there are quite a few threads on here describing the fix. The seals are on the impellar shaft. Good luck.

Share this post


Link to post
Share on other sites

Hey hey you should also order the impeller shaft to its most likely worn and will just where out the new seals.

Share this post


Link to post
Share on other sites

Copied and pasted from the FAQ sticky!

Q: There's a little hole that dribbles coolant out when the bike is cold, but then it stops. What's that all about?

A: That's the weep hole designed to let you know when it's time to change out the water pump shaft and seals. It happens to all WR's eventually and is a fairly simple repair. It is designed this way so you are alerted to the problem prior to it becoming a major issue. The p/n's for the repair parts are as follows:SHAFT, IMPELLER - 5GR-12458-00-00

OIL SEAL - 93109-11073-00

OIL SEAL,SD-TYPE - 93102-12321-00

BEARING - 93306-00105-00

Austin

Share this post


Link to post
Share on other sites

where is that horse i wanna kick em in the nutz

the starting problem may be a dirty carb or valve adjustment

Share this post


Link to post
Share on other sites

The starting is only a bit of a problem for a few reasons actually. Sitting in garage at 20 degrees during night, just put a Dr D 's exhaust on and messing with the jetting (to rich now). I'll work on that after the water pump is fixed.

It kind of sucks that it already needs this stuff done to it. It's only a year old with about 1200 miles on it, just about all dirt. I would have figured a few more years before something like this. I'll get the items ordered tonight, seems pretty easy looking at the shop book as stated.

The bike is awesome either way!

Share this post


Link to post
Share on other sites

I just replaced the seals in mine tonight. It's pretty easy took about 2 hours being overly cautious.

Share this post


Link to post
Share on other sites

I think there is an inner and outer seal.....I have had the outer one go bad and leak from that hole. I guess the inner is a little more of a bitch to change than the outer.

Share this post


Link to post
Share on other sites
is it really necessary to get a new bearing?

I didn't but I also reused the shaft. The bearing and the shaft seemed fine. I will know soon enough after a few rides if it will be ok. A Lot of guys have just changed the outer seal and have been just fine. If the bearing is still tight and spins smooth you should be fine.

Share this post


Link to post
Share on other sites

I ordered these parts from thumpertalk which was about $50. I'll see what the shaft and bearing looks like when I tear into it but more likely than not I'll just replace them. Rather do this once since I'll need to drain the oil and coolant.

Any reason to replace the impeller while I'm in there? I hear you can get an aftermarket one that moves more volume. I haven't had any overheating issues and just engine ice.

MAHA_5GR-12458-00-00 Yamaha SHAFT, IMPELLER

YAMAHA_93102-12321-00 Yamaha OIL SEAL,SD-TYPE

YAMAHA_93109-11073-00 Yamaha OIL SEAL

YAMAHA_93306-00105-00 Yamaha BEARING

Share this post


Link to post
Share on other sites

i ordered the whole kit and couldn't tell the difference between the new and old bearing. i changed mine in summer and it fixed it, but when it's cold it leaks a little when i start it, it stops after like two drips. Other guys say the same, it's normal as long as it doesn't get in with your oil. just make sure your oil isn't milky at all.

Share this post


Link to post
Share on other sites

Not to re-hash and old topic, but here i go. This was the reported fix for the 2007 WR450. My bike is a 2006 WR450, but it's having the same problem. Do the parts listed above translate to the 2006 as well? 

Also, is there a tutorial or how-to anywhere online on how to do this? 

Share this post


Link to post
Share on other sites

Not to re-hash and old topic, but here i go. This was the reported fix for the 2007 WR450. My bike is a 2006 WR450, but it's having the same problem. Do the parts listed above translate to the 2006 as well? 

Also, is there a tutorial or how-to anywhere online on how to do this? 

 

They might be the same parts but to be sure you should check the OEM parts schematic at the thumpertalk store or RMATV.

 

You should buy the seals and impeller shaft .

 

Or you can buy an aftermarket water pump and it will have all the parts you need plus it moves more water.

Share this post


Link to post
Share on other sites

Is there an actual noticeable differnce when getting an aftermarket water pump? I was riding this past weekend at high altitude (11-13k feet), and the bike was getting pretty damn hot. Will this make anactual difference in the bike's running and reliability?

They might be the same parts but to be sure you should check the OEM parts schematic at the thumpertalk store or RMATV.

 

You should buy the seals and impeller shaft .

 

Or you can buy an aftermarket water pump and it will have all the parts you need plus it moves more water.

Share this post


Link to post
Share on other sites

Is there an actual noticeable differnce when getting an aftermarket water pump? I was riding this past weekend at high altitude (11-13k feet), and the bike was getting pretty damn hot. Will this make anactual difference in the bike's running and reliability?

 

It runs cooler for sure, but only when you have good airflow .

 

Don't know how much it helps when you are just creeping along , but that's where a fan comes in handy.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0