Stock tripmeter?

My 03 450's GEAR UNIT ASSY on the front wheel is bad. I'd like to reconnect up the tripmeter but in order to get that new part it's $78.00. Should I just go for an aftermarket for slightly more that has other functions as well (Speed / RPM etc.). How do the after market units install - hopefully they don't use that same part?

My 03 450's GEAR UNIT ASSY on the front wheel is bad. I'd like to reconnect up the tripmeter but in order to get that new part it's $78.00. Should I just go for an aftermarket for slightly more that has other functions as well (Speed / RPM etc.). How do the after market units install - hopefully they don't use that same part?

i have a stock OD off my 08 wr that will work just fine on your bike as far as the drive goes...you might have to play with the wiring a little to power it but all in all it will work just fine. pm me if interested:thumbsup:

I did the 07 conversion on my 05. works like a charm. just install the sending unit on the hub and connect three wires. one constant hot, one switched hot and one negative. The fourth wire on the electronic odo is the infamous nuetral wire trigger. Not sure it it even works? All the wireing you need is just above your headlight and connected to the stock on/off button. Took me about 20 minuted to install mine. Asuming you have the mounting bracked already figured out.

Many like the Trail Tech Vapor use a magnetic sensor instead of the drive unit.

im interested in this to how do you fit the sender to the hub?

It has a small bolt with an integral magnet, it replaces one of the brake rotor bolts. A pickup is mounted to the the brake caliper mount. The trail tech web site has directions, that go over the process, so you can see what is involved before you plunk down the cash. BTW, TT store sells the units at a good price.

I have a '07 WR450F with the electronic spedo and odometer with the mech sender and cable. If you guys are switching to the trail tech computers are you replacing the mech sender with a standard axle/hub spacer? Has anyone replaced their front wheel with a YZF front wheel and needed to eliminate the spedo, replace the axle and use a different spacer? Is this recommended?

thanks

The 03 has a totally mechanical spedo, there are NO wires on the speedo drive. The problem that you have is the part of the speedo drive is a press fit. Remove the wheel and the drive, take the drive apart and you will see the flat plate has come loose from the drive gear. it will most likely be warped looking. Tap it back flat again and press it back over the driven gear. Use a socket just big enough to slip over the shaft. Make it snug and it should work again for a long time at no cost other than a little time.:thumbsup:

Jim

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now