Sign in to follow this  
Followers 0
siscokid7

Ready SS oil filter cover

10 posts in this topic

Does anyone here run it? I installed mine last night and went for a ride today. A small bead of oil started leaking from around the billet cover. The ready filter only has one opening and I assumed it goes on the same way a stock filter does. But I am not sure. My dealer doesnt know either. So I switched it to see if it would run on the opposite side. Again after about 2 minutes it started leaking again. I took the o-ring out and cleaned the groove on the cover and the face of the oil filter plate and reinstalled. It ran at idle for about 4 minutes then leaked. I cant tighten the billet cover any further and I dont want to damage the bike. Any suggestions? The cover is nice but I cant return it unless it is defective for some reason, but it looks fine. :bonk:

Share this post


Link to post
Share on other sites

You will need to call them and ask them to send you an over sized "O" ring. I have used these for years and every time I need to ask them for an over sized "O" ring.

1 person likes this

Share this post


Link to post
Share on other sites
You will need to call them and ask them to send you an over sized "O" ring. I have used these for years and every time I need to ask them for an over sized "O" ring.

Thats it!! Thanks alot! :bonk:

Share this post


Link to post
Share on other sites

I would use the stocker. Like Grey has said in the past. The stocker has a tab so you dont put in the filter backwards.

Share this post


Link to post
Share on other sites
I would use the stocker. Like Grey has said in the past. The stocker has a tab so you dont put in the filter backwards.

Yeah I did notice that. I talked to my neighbor and he said the SS filter goes in the same way as the stock one. I do like the tab, but I gave my stock cover to my brother in law already. :bonk: So now I gotta use the ready cover. Oh well. It looks trick and hopefully with the new O-ring it should work fine now.:bonk:

Share this post


Link to post
Share on other sites

both my dad and i run the ready ss filters and covers on our 06 and 07 and they are fine for us and we used the oem o-ring. maybe yours got warped somehow, call up ready and ask for a replacement.

Share this post


Link to post
Share on other sites

I have Ready SS filters in both bikes, both leaked on the first ride. I emailed RR and they told me to send them back for replacements. I decided it wasn't worth the shipping that they won't compensate me for. I slapped the stockers back on.

Share this post


Link to post
Share on other sites

I installed SS oil filter cover and the dam thing leaks And I can't find my stock cover to put back on, Too bad I didn't read this thread first because I would of never bought it!

Share this post


Link to post
Share on other sites

Mine leaks too, I put some silicone in the o-ring grove, let it cure for an hour, the re-installed the o-ring and installed on the bike , it doesn't leak anymore. This is my 2nd cover from them, the first one had a leak around a freeze plug they use to plug a hole they needed to drill in manufacturing.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0