Sign in to follow this  
Followers 0
bluebreadtruck

Turn signals not working at idle

10 posts in this topic

I have a baja designs kit on my bike, and it has a little battery.

When i hook a battery charger up to the battery it works fine, and for a bit after, then it seems to discharge and run only on the stator...

At idle the voltage is soo low, the headlights dim down REAL low, and basically the turn signals wont even flash unless i blip and hold the throttle a bit.

is there a way to get more power from the stator, or should i wire my headlights on a on/off so i can shut them down? thanks

i have a acrebis headlight with the 2 small bulbs

Share this post


Link to post
Share on other sites

switch to led blinkers .

your blinker relay is to high amperage . get a lighter one .

and you should get your stator re-wound or get a aftermarket one .

Share this post


Link to post
Share on other sites
switch to led blinkers .

your blinker relay is to high amperage . get a lighter one .

and you should get your stator re-wound or get a aftermarket one .

exactly need to do the stator mod or get a bigger one, i have done the stator mod to my bike and have not had one problem in over 3000 miles

Share this post


Link to post
Share on other sites

How old is your battery? What is the at rest voltage, at idle and at speed (3,000 rpm and above).

Bike off should be 12.8 or above. At idle, it should be 13 or above, at 3K, it should be 14 to 14.5

Share this post


Link to post
Share on other sites

There are three times to check voltage, Off, lights on at idle, lights on at speed. You want to ensure the stator and regulator ar getting power to the battery and that the battery is good.

Stator mod is when you combine both sections of the stator together, use a heavier duty regulator/rectifier and channel all the power to the DC side of the wiring. All lighting then gets run off the battery. For example, my WR250 had two sections. A 35 watt to power the headlight and a 70 watt to charge the battery. Combining them geve me 105 watts to charge the battery and all lighting was converted to run off the battery.

Share this post


Link to post
Share on other sites

thanks, my baja designs kit may allready have done that...it has an aftermarket regulator in the airbox and the stocker removed. I found if i raised the idle a bit i am able to get the blinkers to work...so its right on the edge....

i will replace the blinkers and taillight with leds to hopefully make up for teh more wattage headlamps

Share this post


Link to post
Share on other sites

i would still look into a relay . you should also check the battery like william1 said . and your charging system like he said . no point throwing new parts on it if the battery is bad .

a multi meter can be bought for around 20$ if you don't have one .

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0