Sign in to follow this  
Followers 0
minty0_10

2005 leeking water pump?

15 posts in this topic

just noticed a couple of drops of water on the floor under the water pump.

closer look and it seems to be coming out of the small hole on the bottom of the pump cover.

this cant be normal right?

does it mean the pumps about to give up?

the bikes only done 1200k

anyone with any advise please

Share this post


Link to post
Share on other sites

it means your seal is leaking, you'll have to remove the clutch side case cover to do the job. Since it's very minor, it can likely wait until the next required oil change (since you have to drain the oil).

Drain antifreeze and oil

Remove rad hoses.

Remove clutch side case cover - try to save gasket.

Remove water pump cover - O-ring should be saveable if it's the first time.

Remove impeller

Pull shaft out (to backside of cover)

Pull both seals towards water pump side (best to replace both)

Inspect bearing and impeller shaft (on oil side) - should be fine - minor shaft imperfections can be buffed out using emery cloth.

Install new seals (correct orientation is VERY important)

Assemble in reverse order.

Also recommend a clutch inspection since you have it all open.

Probably a 2 hour job with clutch inspection

Share this post


Link to post
Share on other sites

great thanks for the detailed reply, is the pump left or right hand thread?

intend to get it replaced asap, how long will it last for? how often to these seals fail? its only done around 800 miles from new!

Share this post


Link to post
Share on other sites

normal - lefty is loosey - righty is tighty - I place the key in a vice and use an airgun to crack it loose.

The seals always seem to be a problem - no matter what make - probably the most common part to fail on watercooled dirtbikes - just make SURE that the seals go in the right way around - just as they came out.

With that low of a mileage it'll likely only need the two seals, and you might even get away with just the coolant side, but I'd do both.

How long will it last 5 days to 5 years - don't know - seems to be a luck of the draw thing.

Share this post


Link to post
Share on other sites

make sure to check that impeller for scoring too. i doubt it's in too bad of shape with that new of a bike. if there is scoring, the impeller should be replaced too.

Share this post


Link to post
Share on other sites

I use an air rachet to loosen the impeller nut, carefully remove the seal and pop a new one in. The only cover that has to be removed is the impeller cover this way. Fill it up with coolant and thats it.

Share this post


Link to post
Share on other sites

It's impossible to properly inspect/debur your impeller shaft. Seals tend to go because of impeller shaft problems, so you're not really fixing the issue, just band aiding it for a period of time.

I knew a guy who filled the weep hole with silicone to fix the drip, took even less time and effort, but ended up costing him a lot more in the end.

Share this post


Link to post
Share on other sites

I have just lucked out in the past and not had further problems....I see what they're saying if the shaft is buggered up.

Share this post


Link to post
Share on other sites

ok well thanks for all the imfo i,l have to wait and see till i get it off to have a look, i,l report back with any more problems witch i hope theres not as i say it only low poxy miles :excuseme:

Share this post


Link to post
Share on other sites

Mine leaked at about 1000 miles. I changed just the water seal and noted that the shaft was expressively worn but didnt want to go to the trouble of fixing the whole thing cuz I didnt have the parts and werent is stock. I replace the water seal and seated it in a little different position and then put in engine ice. My bike has another 600 miles on it and never overheats and spits up fluid when I am going slow with my kids in the heat. I think engine ice should be an option for you too. Jason

Share this post


Link to post
Share on other sites

well so far ive bought both new seals and a new bearing dealer said while your in there may as well do it all. they arnt expencive so i thought why not.

anyway since buying them........

nothing not a drip not even a splash nowt nothing at all!

so i think im going to wait a little while and see what happens?

Share this post


Link to post
Share on other sites
just noticed a couple of drops of water on the floor under the water pump.

closer look and it seems to be coming out of the small hole on the bottom of the pump cover.

this cant be normal right?

does it mean the pumps about to give up?

the bikes only done 1200k

anyone with any advise please

It's just the idicator that your seal will need to be replaced soon. Same for me on my 05. No biggie...... Just put the bike on a stand, turn on FUEL TV, crack open a coldy, clean off the bench and break out the tools.

Just take your time, it's pretty easy. When I did mine, I replaced every seal on that side since I had it open. 3-hours labor and about $25 in parts.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0