Sign in to follow this  
Followers 0
dmckinno

Carburator leaking gas out of starter squirter rod

3 posts in this topic

I suppose that's not the most technical term, but the Yamaha microfiche lists the part as the starter rod. Anyway, I'm leaking a pretty significant amount of gas out of the junction between part 39 and the carb body in the catalog and where I drew the red arrow in my picture. I pulled the carb off last weekend to try to address the problem, as I thought my float was just stuck, and saw some red flakes in the bowl that spring 33 sits in. I assume I just need to replace an O-ring or something obvious once I pull it apart again, but has anyone here fixed a similar problem?

2e0quqc.png

jj9oit.jpg

dff0g8.jpg

Share this post


Link to post
Share on other sites

That's your AP circuit - Accelerator pump - it means the diaphragm is leaking from the wet (spring side) to the dry (rod side).

Replace the diaphragm - while you got it out - clean the entire carb while you're at it.

Share this post


Link to post
Share on other sites
That's your AP circuit - Accelerator pump - it means the diaphragm is leaking from the wet (spring side) to the dry (rod side).

Replace the diaphragm - while you got it out - clean the entire carb while you're at it.

Yes, I agree w/ Matt. I have gone through three of them. Race fuel U4 is really hard on them.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0