o6 yz450f keeps dying at an idle

i have an 06 yz450f thats been rode pretty hard,never any problems before.i think i might have gotten hot the last ride ,did the oil,cleaned the filter ,but now once i start it and ride it for a minute it want to die if i let the throttle drop to an idle then it gets tricky to start again,but if i keep on the gas its just fine. Can any tell me why this is happening and maybe how to go about fixing it?:thumbsup:

What happens if you simply raise the idle speed? (big silver slotted screw, left side.)

Check to see if your pilot circuit screw fell out, it happens.

Check to see if your pilot circuit screw fell out, it happens.

Yeah, That's it. I believe it would idle a bit higher.

Yeah, That's it. I believe it would idle a bit higher.

No, it won't idle at all. Welcome to TT.

the timing chains are crap on '06s. Pull the cam cover off and try to position the timing marks at top dead center. If you cant get it then you timing chain has stretched and jumped a few teeth. MY '06 did this same thing at about 15 hours of riding. 2 more teeth jumped on my exhaust cam and it would have been kaboom. I replace my timing chain once a year now. They are 13 dollars at any Yamaha dealer. Check it and make sure.

thnx macjammer i will check and see how my timing is im leaning more in that direction because i have checked the obvious like the others have mentioned above,i was wondering if maybe it would have something to do with valves or top end?

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now