99 yz400f spits and sputers in the mid range power

im not sure if its carb related or electrical. i cleaned the carb a few times now & checked the wireing. all seems fine. anyone else ever had this problem? if so what can i do to fix. thanks

Did it run clean prior same temp, fuel,etc. Nothing was change to the motor correct?

my 99 started running bad once like that and it was a clogged gas cap vent.

pretty easy to verify, just open the cap about a half a turn when it does the spitting. Mine was so bad you could hear the pressure escape. it also was pushing fuel out the overflow hose. I had never had a bad gas cap before that one.

as bigred said too has anything been changed on the bike ????

correct nothing on the motor i just changed the tank to a bigger desert tank and it sat for a while so im in the process of going through the carb completely as we speek. hope that does it. thanks

i am having problem with the gas overflowing also thanks ill check that out also

i am having problem with the gas overflowing also thanks ill check that out also

i meant to say that the gas was coming out of the vent hose on the gas cap on mine. Sorry... trying to work and type is hard on us old guys,:thumbsup:

... trying to work and type is hard on us old guys,:thumbsup:
Watch it.
Watch it.

sorry sir. it probably not the age, it's the mileage... :thumbsup::worthy::busted:

on me anyway

(it's) not the age, it's the mileage...

Or the fuel, maybe? :thumbsup:

Or the fuel, maybe? :thumbsup:

could be.... im on premix now you know.....

correct nothing on the motor i just changed the tank to a bigger desert tank and it sat for a while so im in the process of going through the carb completely as we speek. hope that does it. thanks

How long has the gas been sitting in the tank? Does the new tank have a short vent hose coming off the cap?

i put fresh fuel last week half race 101 octane, half 91 octane. i never ran it with old fuel though im pretty good about that. i did order a accelerator pump for it last weekend had a pretty bad tear in the diaphram. ya think that would make it cut out in the midrange? i should have it back together tomarrow. thanks for the info

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now