How do I wire horn with this switch?

Hello. I have the switch that is in this link. http://www.procycle.us/images/dualsport/comboswitch_mini.jpg

How would I wire my horn with this switch? Currently I have the yellow hooked to my main power, the blue to my highbeams, white to low beams. Lights work fine. The horn though, I'm unsure about. As on the switch there is a specific place for Headlight Main and Blinker Main, but the horn has no main so please help. I hope I make sense. Thanks alot.

Mike

If I had to do it from that link I would ground the black wire, then hook up the ground wire from the horn to the light green wire. Seems like that setup completes the ground circuit for the horn.

The (Main) for the horn would be just a 12volt source to the horn.(nothing to do with the switch)

The blinker and headlight use a main because it takes in the 12volt signal, then the switch directs that power to your high beam/low beam , left blinker/ right blinker.

As mentioned the horn is wired directly into your 12volt power so it needs no main. It just uses the switch to complete the ground.

Hope this helps

Does your horn have 2 terminals? One should be for pos and the other is neg. Hook the wires from the switch accordingly. The switch can do one of 2 things, closes the pos circuit when the button is pushed or it will do the same with the negative.My quess is the negative. If the horn is self grounding then the ground wire from the switch can be grounded to the chasis as mentioned above. my horn has two terminals though.

Thanks guys. I got it hooked up. It works when at idle but when I reve the bike in neutral the horn doesn't work anylonger, when it let it idle it works again...regardless it sucks as far as noise goes.

Thanks guys. I got it hooked up. It works when at idle but when I reve the bike in neutral the horn doesn't work anylonger, when it let it idle it works again...regardless it sucks as far as noise goes.

Do you have a battery wired into the system?

A battery? My stock battery is on the bike, not sure if that is what you mean.

I have the horn working properly now at idle. It is real loud. All I did was install thin rubber between the bolts on the horn mount. When I rev it up in neutral though I still can't hear jack.It is working but is barely audible. I'm not sure if this is a vibration problem as vibrations are increased drastically reving in neutral, or if it is something with the horn not liking AC. But if it works at idle I don't see why it wouldn't work at higher speeds. Tomorrow I will take it for a test drive and see how it works in gear, and maybe try to isolate the mount more. I have heard something about a 9volt battery being used for a horn...whats this all about and how often does it have to be changed. Thanks for the help.

If the horn is for motorcycles, it's more than likely that the horn needs DC current. If you have it tied into the headlight circuit, then you're sending AC to it. I'm just guessing here, but it probably runs at idle because the voltage is lower at idle. As the voltage comes up as it revvs, the AC effect kicks in and makes the horn not work. If you intend to use the horn you have, you will need to rectify the current to DC.

The URL at the bottom of my sig may give you some help.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now