HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
yzzzz426

help

3 posts in this topic

alright i fouled a plug the other day so i fixed it, and while i was at it i changed the oil. now when i start the bike it clicks like its low on oil(that is what me car does i dont know about bikes but its the same clicking noise) and when ever i try to put it in first it pops the clutch if i put it in 2nd and let out the clutch works fine what the f did i do:eek:

Share this post


Link to post
Share on other sites

Make sure you have the proper amount of oil in there, follow the procedure for checking it laid out in your manual.

Share this post


Link to post
Share on other sites

remember when checking oil level check whil engine is not running. dont screw in dip stick. Also when running losen the top bolt at back of head on oil line for oil return to make sure you have oil pressure and flow to the head. you could also check all o rigs and filter for proper install.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0