HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
purepolaris88

04 Yz450F Problems

2 posts in this topic

I Just recently Replaced the clutch & plates in this beast took it for a test ride , it was running excellent before , ran and bog out and died, wouldent kick start , when i bomb start it runs , but has no balls and half to hold it half throttle or more , any ideas?

Share this post


Link to post
Share on other sites

Mine did the same thing its a 06 450f and the valves needed to be adjusted since then I have adjusted them 2 times and now I need a new set of vavles because the hard coating has worn off of the titanium vavles. Would recommend Kibblewhite stainless steal vavles. Wont wear out as quickly. It wouldnt kick start and had to bumb start it and hold the throttle open to start it when I could kick start it. Try that and see if it helps.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0