engine sputtering..need help

'03 yz450. new engine, Pro-circuit pipe, zip-ty carb mod. I just plated my bike and i notice that if i am not accelerating and i am in the higher RPM range at a constant throttle position then my bike is sputtering. Have no idea what it is or how to fix it.

anyone know anything about this or know how to fix it?

sounds like a jetting issue to me

sounds like a jetting issue to me

yeah thats what i figured, just dont know how to go about fixing it.

Go back to stock jetting and start from there, never heard of a zip ty mod, what is that?

How big is your main jet/pilot jet?

Go back to stock jetting and start from there, never heard of a zip ty mod, what is that?

I am at stock jetting right now, i have never changed it. Zip-Ty mod is a racing modification, do a search for it on here and you should find plenty of info about it.

How big is your main jet/pilot jet?

I havent touched my jetting since i bought the bike, so the jet is still the same size that come stock. I am not really sure what the exact size is off hand, i can look it up if you need me to.

If the sputtering seems very regular at a steady throttle, try dropping the needle one notch (put the clip higher up on the needle) and/or running the pilot screw a little farther in. If the sputter is irregular, or erratic, and accompanied by the occasional pop in the exhaust at steady throttle, try raising the needle instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now