HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
trader20

06 WR450 - displaying the odometer (not tripmeter)

17 posts in this topic

How can I display the odometer reading (non-resettable total miles) instead of the A/B tripmeters? The 06 WR450 manual indicates that there is an "odometer" (I presume non-resettable) in addition to A/B tripmeters. page 1-16 of the manual shows that in basic mode, by pushing SLCT2 repeatedly, you cycle through "Odometer->Trip A->Trip B->Trip A->Odometer". However, when I repeatedly push SLCT2, the display just alternates between Trip A and Trip B. I cannot get the unit to display the non-resettable total miles odometer.

Can anyone tell me how to do this?

Share this post


Link to post
Share on other sites

I know for a fact there is no odometer on a US model wr . that is why I threw out my stock unit out . a major strike out for yamaha :):D:worthy: .I mean how stupid are they . As far as I know it's only on the aussie bikes and maybe the europe one too.

if you check the overseas parts books , think there are 3 differant part # s for the od

Share this post


Link to post
Share on other sites

My 06 is a US model, and it was definitely showng an odometer reading... I ran it up to 1000km (I used trip meters for fill ups) then did the free mods and couldn't get the odometer back!!!! maybe it has something to do with disconnecting the Grey wire?????

Share this post


Link to post
Share on other sites
My 06 is a US model, and it was definitely showng an odometer reading... I ran it up to 1000km (I used trip meters for fill ups) then did the free mods and couldn't get the odometer back!!!! maybe it has something to do with disconnecting the Grey wire?????

I have my grey wire disconnected and didn't do anything to the computer. I know the new generation 07-on don't have an odometer function but I thought all the 06's did.

Share this post


Link to post
Share on other sites

my 06 has it for sure. speedometer is working though, need to take a look to see why. anyone have any thoughts on that?

Share this post


Link to post
Share on other sites
I know the new generation 07-on don't have an odometer function but I thought all the 06's did.

the 06 and o7 have the same part # here in the USA . there is no odometer on them. I'm 100% sure of it. I spent 3 weeks researching it a year ago . That is why my dash looks like this.

DSC00922.jpg

Share this post


Link to post
Share on other sites

well i know the cnd bike 08 has trip a > trip B > odometer

i would think if there is a trip there is a odometer. doesn't make sense!

cheers

Warts

Share this post


Link to post
Share on other sites
the 06 and o7 have the same part # here in the USA . there is no odometer on them. I'm 100% sure of it. I spent 3 weeks researching it a year ago . That is why my dash looks like this.

Its strange that people in this thread among other older threads on this subject report 06 US spec bikes with odometers and some without. And then there is people with odometers that dissappear mysteriously which leads me to question the quality of the speedo and that maybe some of them are faulty? :thumbsup:

Share this post


Link to post
Share on other sites

well I'm not sure that they were really seeing a odo or just trip b . If they are seeing a odo reading I'd really like to see a pic for proof with a reading above 1001 miles on it . As far as ,the how good a yamaha speedo is , know mine was way off on top speed , on the note of 17 mph . I never ran mine long enough to have it fail .

Share this post


Link to post
Share on other sites

Bikecomputer.jpg

This is trip A that I use for Petrol fill ups (Use like a petrol gauge, reach 55 miles & start looking for a petrol station !)

Bikecomputer1.jpg

Trip B I use for oil changes.

Bikecomputer2.jpg

The odometer that I wish I could reset before the first mot is due :thumbsup:

Share this post


Link to post
Share on other sites
well I'm not sure that they were really seeing a odo or just trip b . If they are seeing a odo reading I'd really like to see a pic for proof with a reading above 1001 miles on it . As far as ,the how good a yamaha speedo is , know mine was way off on top speed , on the note of 17 mph . I never ran mine long enough to have it fail .

Good point on the Trip B mistake. It sure sounds like it from one of the posts earlier in this thread. So, European, Australian and Canadian bikes all have the odo but US don't. Thats just facked.

Share this post


Link to post
Share on other sites

I have a 06 wr450 and the previous owner had it california plated and it still had a green sticker. Now that I am trying to register it the DMV is saying they want to see the odometer.

Any ideas?

Share this post


Link to post
Share on other sites

just run some miles onto trip b and show it to them . or install a vapor or somthing like a vapor. you can program a vapor to show any mileage you'd like so it can have you real total miles if you would like it to.

Share this post


Link to post
Share on other sites
Bikecomputer.jpg

This is trip A that I use for Petrol fill ups (Use like a petrol gauge, reach 55 miles & start looking for a petrol station !)

Bikecomputer1.jpg

Trip B I use for oil changes.

Bikecomputer2.jpg

The odometer that I wish I could reset before the first mot is due :excuseme:

that's not a US model bike . I want to someone with one here that works

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0