450 missfiring help!

Ok here goes it...07 yz450 stock with fmf 4.1 with jd kit installed.

The bike has a bad miss fire above half throttle and i think its an electrical miss. I've had it on a dyno and have the readings to prove that its not jetting(air fuel metter readings) Anyone have any problems with the cdi boxes on these bikes? And also I did unplug the TPS with no luck, also checked the nuetral switch out with an ohm meter and it is within specs....so this is killing me...thanks to all who replie:thumbsup:

i had a couple miss fires on my 07 but all i did was put a adj fuel screw and a 48 pilot jet in and it clean it right up

yep thats what it sounds like alot of them are doing but not mine of course..

Yep my 07 yz450 did this as well with the DR.D full system, after calling them and rejetting it didnt help. removed and reinstalled stock pipe and it cleaned right up,sold DR.D on Ebay and riding stock now. A Yamaha rep said that with the new 07 and up cams and ignition specs it doesnt help to add an aftermarket pipe unless you change the cams. they said its designed to run slightly corked up. Hope this helps.

Check the ignition coil connector. I had the same problem,

[...] the new 07 and up cams and ignition specs it doesnt help to add an aftermarket pipe unless you change the cams. they said its designed to run slightly corked up.

 

Not true.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now