HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
mxjosh

Hinson Inner Hub ? Pls check out pic if you have one.

8 posts in this topic

Got this off Ebay claimed as new. Ended up being mislisted for my bike (I have YZ250) so I turned around and sold it on Ebay. Buyer did not like the way it looked and filed a claim stating the silver part was machined so it is not new as I said in the auction. He called Hinson as well and they stated the entire piece is coated. There are no grooves are markings were the steel plates slide in and the silver surface is perfectly smooth.

Was yours this way? And do you know of any reason why it would look this way?

This is for a 2003-06 YZF450 or 2004-2008 YFZ450

purchased.jpg

IMG_8298.jpg

Share this post


Link to post
Share on other sites

The part looks new, but does it have "Hinson" engraved in it on the back side?

Share this post


Link to post
Share on other sites

Yeah but thats just a general picture for all bikes. I was hoping for something more specific to what bike it is actually for.

Hinson is engraved along with the bikes it is for.

Share this post


Link to post
Share on other sites
Yeah but thats just a general picture for all bikes. I was hoping for something more specific to what bike it is actually for.

Hinson is engraved along with the bikes it is for.

o sorry, but yea like greyracer said it does look like it was never used befor?

Share this post


Link to post
Share on other sites

Is there not a part number stamped into it? Agree it should be all black - from looking at it it could be for many different bikes....

Share this post


Link to post
Share on other sites

H198 is the part #.

It is almost exactly like my YZ one but the back of it is raised slightly so the push rod doesn't connect with the pressure plate.

Share this post


Link to post
Share on other sites

maybe an older model before they started complete coating them? maybe time for you to call hinson. ski

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0