Sign in to follow this  
Followers 0
brent426

new head and valves...Lapping????

6 posts in this topic

I just got my brand new 426 head and all valves. Do I need to lap these valves to the new seats or are they good to go? If I do, what is the recomended procedure.

Share this post


Link to post
Share on other sites

What year is your 426?

If it's a 2000, lap them, it has steel valves. If it's a 2001 or 2002, don't lap them, you wear the coating off the Ti valves.

Share this post


Link to post
Share on other sites

this is a 2000 and I ordered the valves from thumpertalk oe store. Have the valves been updated? Are these steel or titianium?

Share this post


Link to post
Share on other sites
this is a 2000 and I ordered the valves from thumpertalk oe store. Have the valves been updated? Are these steel or titianium?

If you ordered them for a 2000 then they should be steel. If that is the case then it is ok to lap them. I assumed it was one of the titanium valved 426's in my first response, you know what they say about assuming...

Share this post


Link to post
Share on other sites

If the valves were roughly $20 each, they're steel. If they were closer to $80 each, they're Ti.

Perhaps a better way to tell is by the part numbers. Steel valves will have a 5BE prefix, while the Ti parts will have 5JG instead.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0