HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
PoorComa

Cleaned carb, now no fuel/no start...help please.

9 posts in this topic

Even thought I've never messed with a carb before I decided to go ahead and remove/clean mine. I'm not sure that I did it right but all seemed to go well, took the top and bottom off and sprayed it out really well will with carb cleaner and some compressed air. Looks like new.

Put the bike back together and as soon as I turned the petcock to 'on' fuel fcame right out the bottom of the carb. From what I've read this would tell me something is wrong with the needle valve...? Well, I took the carb back off and took the float bowl off and made sure to clean the needle valve assembly well.

Back together once again and the fuel no longer flows out the bottom of the carb:applause: .....but it doesn't flow at all!:thumbsup: What did I do? Fuel will flow freely from the tank but for some reason it will not flow into the carb....gave the bike numerous kicks thinking is would draw the fuel in but nada.....any ideas? I'm clueless and just starting to learn. Thanks a lot!

Oh, the reason for the cleaning is that I was having a bad hesitation/jerking problem just off the low/mid-low revs. Also, I replaced the floatbowl gasket since fuel was leaking from the crack between bowl and carb body.

Share this post


Link to post
Share on other sites

If the fuel does not flow at all . your float valve is stuck shut now. I think I would pull the carb back off . take the bowl back off and get the float working right before you put the bowl back on this time . you can test it by hooking fuel up to it and work the float with your finger .

Share this post


Link to post
Share on other sites

well I just took the carb back off since I just read another thread concerning the pilot jet (I believe) and I too didn't realize that is was adjustable and just screwed it all the way in....I backed it out 7/8 and just shook the carb up hoping to free anything that was stuck (I can hear the float moving free)....put it back together AGAIN...and after a few kicks I got her started!!!...Now to get it all back together and see if it runs better or worse...lol.

Share this post


Link to post
Share on other sites

It all works again which is good......but I still have the jerky operation at mid revs.....not as bad but still there. Any ideas? Anyone?

The bike does return to idle promptly now once I let off the throttle where as before it would like to hang up at higher rpm before returning to idle (if at all).

Share this post


Link to post
Share on other sites
It all works again which is good......but I still have the jerky operation at mid revs.....not as bad but still there. Any ideas? Anyone?

The bike does return to idle promptly now once I let off the throttle where as before it would like to hang up at higher rpm before returning to idle (if at all).

Is it at a constant throttle? If so check the adjustment of your TPS. You can also disconnect it and if the problem doesn't go away you will have eliminated it as a suspect. Next try moving the clip on the needle down one notch as it may be starving for fuel. How does the plug look?

Share this post


Link to post
Share on other sites
Is it at a constant throttle? If so check the adjustment of your TPS. You can also disconnect it and if the problem doesn't go away you will have eliminated it as a suspect. Next try moving the clip on the needle down one notch as it may be starving for fuel. How does the plug look?

I haven't taken a look at the plug yet but I'll do that after I get back from the river today (tubing). And yes, the problem is VERY BAD at a constant throttle setting so I'll check out the TPS as well. I'm not sure how to move the clip on the needle but I'm sure I can figure it out if I have to take the carb off again..hopefully I can fix without another dismantle. Thanks for the input!

Share this post


Link to post
Share on other sites

I think you can remove the needle by just spinning the carb and removing the cover. Grip the clip on the needle with a pair needle nose and put it one groove lower but be careful the sucker is small and easy to lose. Good luck and let us know who it turns out!

Share this post


Link to post
Share on other sites

Don't remove the TPS from the carb, just unplug it. If you have removed this in the past and did not set it properly then that can be part of your problem. Also, start by setting your fuel screw at 1.5 turns out and then tune from there. If you still have a hanging idle then lower you idle speedadjustment.

Share this post


Link to post
Share on other sites

Yup, check your fuel screw first...easiest fix then go from there. I made the mistake of cleaning my carb, tightening the fuel screw to soak with cleaner, then forgot to back out. Had to tinker for 45 minutes before I realized what I had done...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0