HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
rufusz

strange popping on decel 02 426F

6 posts in this topic

Hi

I've recently did a whole rebuild on the engine, fixed the 5th gear throwing out problem and installed an HotCams exhaust cam with autodecomp and the bike now does strange popping on decel. Beside that it runs better then before (did shimming on the exhaust valves also and on valve 1 of the intake, the rest was ok). So on strong accel and then decel, it starts a series of rapid popping. Before changing the cam it popped fewer times like 2 seconds between poppings, now it's like gunfire 1/second or maybe a little faster :eek:

Any ideas what could cause this? Timing must be right, installed like this :

old intake cam with I punch mark aligned to cylinder head, hot cams exhaust cam one punch mark aligned with cylinder head, other at 12'o clock.

Share this post


Link to post
Share on other sites
Hi

I've recently did a whole rebuild on the engine, fixed the 5th gear throwing out problem and installed an HotCams exhaust cam with autodecomp and the bike now does strange popping on decel. Beside that it runs better then before (did shimming on the exhaust valves also and on valve 1 of the intake, the rest was ok). So on strong accel and then decel, it starts a series of rapid popping. Before changing the cam it popped fewer times like 2 seconds between poppings, now it's like gunfire 1/second or maybe a little faster :eek:

Any ideas what could cause this? Timing must be right, installed like this :

old intake cam with I punch mark aligned to cylinder head, hot cams exhaust cam one punch mark aligned with cylinder head, other at 12'o clock.

Popping is a sign of a lean condition or an air leak. Usually when you do any performance mod, especially a pipe or cams, the motor will become lean. I would suggest that you play with the air fuel screw and if that doesnt make the bike rich enough, go up a size on the pilot or main jets. Hope this helps

Share this post


Link to post
Share on other sites

1. Air leak where?

2. What do you mean to play around with air/fuel screw? How do you know when is the setting right?

Share this post


Link to post
Share on other sites
1. Air leak where?

2. What do you mean to play around with air/fuel screw? How do you know when is the setting right?

When you replaced the rebuilt motor in the bike, you had to put the air boots back on the carb from the airbox and from the carb to the head. These are possible air leak spots. When you mess with the air/fuel screw you can lean and richen the motor out, depending on which way you turn the screw. You need to go richer, when the motor stops popping on decel, you have found the right mixture.

Share this post


Link to post
Share on other sites

forgot to mention turning the air fuel screw counter clockwise will richen the carb, this is what you need.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0