HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
danny-goddard

running rough when hot???

2 posts in this topic

hi there my wr 426 runs mint when i first crack it up but as soon as the engine starts to warm if i rev it the engine takes a while to settle back down?? also when im riding if i give it the beans it misfires a little?? the mods are- throtle stop screw cut down,lid taken off air box, extra holes in air box,yzf header pipe with race end can, standed jetting.:thumbsup: any help will be great cheers danny

Share this post


Link to post
Share on other sites

Hanging idle typically means you need to open the fuel screw more or possibly need a larger pilot or have a vauum leak.

For the other issue, does it run better when cold than get worse as it heats up? If so, the needle is a bit rich, try moving the clip closer to the flat. If it is the opposite, move the clip the other direction.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0