turn Signals wont flash

So I just bought this XR650l and was connecting the turn signals, they come on but they wont flash. Does anyone know what the problem could be?

I'd try a new flasher.

Sometimes when one of the flasher bulbs is burned out the flasher will discontinue.

Maybe the L does that.

Well the turn signal turs on but doesnt blink

All the bulbs must be exactly the same wattage and the flasher must be matched to those bulbs..or the bulbs matched to the wattage of the flasher.Make sure all the connections to the indicators are clean and a good fit...check the earths and make sure their all clean and attached solidly to their respective points ,,,thats all earths not just the flasher ones..Also try starting the bike..Sometimes they won't flash if the batteries a bit dodgy.The xtra power to it sometimes kicks them off.

All the bulbs must be exactly the same wattage and the flasher must be matched to those bulbs..or the bulbs matched to the wattage of the flasher.Make sure all the connections to the indicators are clean and a good fit...check the earths and make sure their all clean ,,,thats all earths not just the flasher ones..Also try starting the bike..Sometimes they won't flash if the batteries a bit dodgy.The xtra power to it sometimes kicks them off.

You bring up some key points. The wattage's must all match. All grounds/earths must be clean. Any difference in resistance will cause some funky stuff to happen.

I figured it out..... I was looking at the wire diagram and realized that all turn signals were connected (duhhh), so in order for them to work correctly they all must be connect. I only had the front 2 connected at first. Thanks for the assistance guys.

thats also a notice to let you know if a bulbs out maybe? alot like a car when ones out the blinker will flash funny and ill bet this may do that also, not certain but sounds like it does.

Where in CA are you? Welcome to TT

thats also i notice to let you know if a bulbs out maybe? alot like a car when ones out the blinker will flash funny and ill bet this may do that also, not certain but sounds like it does.

Where in CA are you? Welcome to TT

Covina/west covina.

I have just read your post as I have the same problem and was going to pose the question!

I will try plugging all in!

Cheers

If all your electrical wiring is good then it should work, u cant just have 1, 2, or 3 lights plugged in all 4 have to be plugged in.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now