Sign in to follow this  
Followers 0
WGP

2006 YZ450 Jetting Help

5 posts in this topic

My 06 YZ 450 has :

170 main, 48 Pilot, 40 Leak, JD Red#5 w/ small O-ring mod, and 2.5 turns out on the fuel screw.

4000' @ 40-60 Degrees

It is very close but still backfires especially when cold:banghead:

I don't want any backfire.....it was worse with the fuel screw at 1.5 turns out...then went to 2.5 out and is better but not perfect..

Any Ideas??

Share this post


Link to post
Share on other sites

In my opinion, you're too rich almost everywhere. Of course, I don't know what your exhaust system is.

I run mine with a 165/45/NFPR(4) and the stock #55 leak jet, no pump mods. This setup stays like this year-round for altitudes running fro sea level to near 4000', and the bikes work fine. In the winter months when the desert temps drop, I run a 168 main, but I don't change much else.

You say you don't want any backfire. I say you have two choices. One is to overjet th eidle circuit until you start having problems with stalling on idle down (closing the throttle in neutral or pulling the clutch in at speed), or sell the YZF. Decel popping is part of their nature, and it's completely harmless at normal levels. What I'm saying is that it's normal for a YZ450 (just as with a lot of sportbikes) to "crackle" on deceleration some. 3-4 subdued pops on decel is fairly normal, and when jetted correctly and running an exhaust that doesn't leak air, they will do this half the time or more. That's the way they are. Excessive decel popping is an indication of an exhaust leak, or a lean idle, but some is normal.

Share this post


Link to post
Share on other sites

I have a stock header with a FMF Ti Powercore.

I know its rich thats why I'm suprised it still backfires? I guess this is as good as it gets? My old WR (05) ran perfect at this setting...never backfired..

When I had 168/45/ it was backfiring way too much....

What would I do too "One is to overjet the idle circuit" ?

So it could be caused by a leak in the exhaust? This is possible my header muffler connection is questionable due to the FMF adapter they provide for stock headers.

Share this post


Link to post
Share on other sites

Apply a little high temp silicon sealer to the pipe and see what happens.

"Over-jetting" simply means jetting too rich.

Share this post


Link to post
Share on other sites
I have a stock header with a FMF Ti Powercore.

I know its rich thats why I'm suprised it still backfires? I guess this is as good as it gets? My old WR (05) ran perfect at this setting...never backfired..

When I had 168/45/ it was backfiring way too much....

What would I do too "One is to overjet the idle circuit" ?

So it could be caused by a leak in the exhaust? This is possible my header muffler connection is questionable due to the FMF adapter they provide for stock headers.

You may want to check your hotstart plunger and make sure it is adjusted correctly. If it is hanging open a little and not seating all the way it will backfire like crazy. I am running the same jetting as Gray racer on my 06 except for an NFLR needle...Dr D pipe and its pretty close to perfect.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0