smokey starts

I have a 95 650L and when I got it ,it also smoked for a few seconds when started. After a few rides it doesn't do it anymore.

The previous owner told me he didn't use it for months when I bought it.

I have no idea also what that was.

That was probably a case of dry guide seals from sitting. Once it was being ridden again, the seals got some lube and started sealing again.

Thanx

SOLVED!!

I think.

Here's what I did.

1st - Drop it on its right side, twice, busting your knuckles.

Then drain oil and remove clutch cover.

Clean and inspect oil pump/lines/screens.

Nothing is too bad, just normal build up.

Replace oil and go for a 60mile ride.

3 cold starts and no snoke, at all.

I hope it is fixed.

SOLVED!!

I think.

Here's what I did.

1st - Drop it on its right side, twice, busting your knuckles.

Then drain oil and remove clutch cover.

Clean and inspect oil pump/lines/screens.

Nothing is too bad, just normal build up.

Replace oil and go for a 60mile ride.

3 cold starts and no snoke, at all.

I hope it is fixed.

So I dont understand what you fixed..... Oh well, at least its good now!:smirk:

Can you show us some video of the dropping technique. I am sure it will need to be done exact to make it work.

Can you show us some video of the dropping technique. I am sure it will need to be done exact to make it work.

All you have to do is try to lean the bike on the handle bar away from the kick stand. Don't pay attention for a second, then miss the post you are trying to set the bar against catching your hand between the bike and your bench vise.

Repeat.

As for what I have fixed, I noticed that the oil level in the tank doesn't drop as fast as it used to. It would be almost empty after a few hours. I think it would totaly fill the case and push by the rings and smoke untill the oil pump caught up.

I must have cleaned out a check valve or something that was allowing the oil to drain quickly. :smirk:

Any ideas??

Thanks,

Dave

Check valve ? does that sound familiar ?

maybe when apart some junk got stuck? Some have springs that go bad and don't hold tight against hole .

I've found many a foul on many differant bikes with sump.

Good luck.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now