XL600R Turn Signals not Flashing? Ideas?

I have a 1983 XL600R and I cannot get the turn signals to flash. When I switch them on (both the front and rear left side or right side go solid) they do not flash?

All the bulbs look good because when I switch it left (both front/rear go solid on the left side) and when I switch it to right (both front/rear go solid on the right side).

Where is the flasher located on this bike? I have the service manual but it does not explain all the details of the flashers.

Thanks

Ya, the flasher might be stuck closed. Not sure where it is though.

Yeah, its the flasher.

The flasher is located under the tank. Take the tank off, and you should see a bunch of electronics between the upper and lower frame spars. Stand on the left side of the bike, and look at the 'cluster' there. There should be a small black box that is located almost directly above the spark plug. The box isn't real big, about an inch tall, about 3/4 of an inch wide, and a half inch thick, if I remember right.

The box sits inside a retangular rubber grommit thing, which slides onto a metal tab. You should be able to get a new one from Honda, however you can also pick up a generic two prong flasher at any auto parts store, and use that in its place. The only problem is, is that the flasher is most likely round, and will not work with the grommit. I was able to zip-ty one into place, and it works great.

The only down side I seem to have found, is it seems that the generic flasher seems drain the battery more than the stocker. I don't know if its the flasher, or something else, though. I haven't been able to isolate the problem. Good luck though.

is this bike new to you? Did the flasher ever work? Did you change the turn signals?

Sometimes if you use a bulb that draws too much or to little current, the blinkers will behave the same way that you are describing....I had it happen on my KLR650 one time when I changed the blinkers, but not the flasher relay.

Yeah, its the flasher.

The flasher is located under the tank.....

Not on an 83 XL600r. Don't pull things out from under the tank.. those are your CDI and Coil.

On your 83, like mine, the flasher is located next to the battery.

2268082900_cc26548df4.jpg

Not on an 83 XL600r. Don't pull things out from under the tank.. those are your CDI and Coil.

On your 83, like mine, the flasher is located next to the battery.

2268082900_cc26548df4.jpg

Thats weird, because I had an 83 XL 600 last summer, and went to replace the flasher, and mine was located under the tank, just like most of the XL's of that era.

Edit: I'm working on an XL350 right now, and for some reason I was thinking it was the same bike. Don't ask, it was a rough couple days... :applause:

That black box under the tank you described was definitely the CDI - which controls engine ignition. I agree - the turn signal flasher is near the battery box. To further one post, I've heard that LED's draw too little power to turn a flasher on. If you're using stock lights, not a prob, but LED's require a special flasher module.

That black box under the tank you described was definitely the CDI - which controls engine ignition. I agree - the turn signal flasher is near the battery box. To further one post, I've heard that LED's draw too little power to turn a flasher on. If you're using stock lights, not a prob, but LED's require a special flasher module.

THANKS FOR THE INFO! I was able to locate a new square 2 prong flasher, and I replaced it. The Turn Signals work perfectly. It cost me $6.99 but it fixed my problem.

THANKS EVERYBODY HERE!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now