HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
smtaylor

08 WR450F Jetting

4 posts in this topic

I just bought a 08 wr450F and installed the dealer AIS kit which included the blockoff plate, jet needle new pilot, main (175) and air jet and leak jet. I also took out the restrictor in the exhaust and removed the grey wire.

Problem is that it won't run on the top end. Great up through mid range, put past that, engine just sputters. Any ideas?

Share this post


Link to post
Share on other sites

Congrats on the new bike! Don't want to make any assumptions here - did you remove the "binoculars" or "snorkel" from the air box (i.e. open it up so it can breathe)?

Share this post


Link to post
Share on other sites
I just bought a 08 wr450F and installed the dealer AIS kit which included the blockoff plate, jet needle new pilot, main (175) and air jet and leak jet. I also took out the restrictor in the exhaust and removed the grey wire.

Problem is that it won't run on the top end. Great up through mid range, put past that, engine just sputters. Any ideas?

My '07 came with a 162 main. I put the JDJetting kit on and the main went to a 168 and the pilot to a 48. I think the 175 is way too rich hence the sputter after 1/2 throttle. Check out the sticky's at the top of this forum. They have what other people are running as far as jetting and other mods.

Share this post


Link to post
Share on other sites
Congrats on the new bike! Don't want to make any assumptions here - did you remove the "binoculars" or "snorkel" from the air box (i.e. open it up so it can breathe)?

Yes. Airbox stuff is removed. I assumed the dealer kit would have the jets dialed in, but I guess the 175 main is too much. I may try putting the stock main back in and leave the pilot (a # 50) and see how that goes.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0