real new guy here. but 500 lover.

so i got my 83 out of storage,and wow its not like i parked it.

well i put a clutch in it from along time ago. (barnett)

well not the thing doesn't disengage it enough to take off from idol. you kick it in gear and it dies.

So i went to bike bandit and looked at the microfiche and i didnt see any missing pieces. Ill ask then tomorrow or the next day ill disect it and get some pictures for you. but any usual suspects would be a help.

thanks alot.

Was the clutch basket notched by the plates? If it is, the notches can hold the plates from disengaging all the way.

Did you soak the new clutch plates in oil before installing?

yeah i soaked them. and the basket had the notches and i fit every disk in there.

its like the linkage is missing a link or something, the rod that goes over the case and pushes it to engagement isnt working or something.

how thick of oil are you running? did you ride it around at all to see if it got better?

yeah i soaked them. and the basket had the notches and i fit every disk in there.

its like the linkage is missing a link or something, the rod that goes over the case and pushes it to engagement isnt working or something.

You might need to go in there again and file down the notches in the clutch basket/fingers. And it seems obvious, but make sure you've adjusted the cable at the lever perch and at the other end of the cable near the arm on the left side of the block so it pulls enough to disengage the plates. Otherwise it sound like you did everything fine. Hope this helps. :banghead::busted:

+1 on filing the notch's.

It might just be a case of stuck plates from sitting.

Dave

What he said ^^

I have never had good luck with Barnett clutch fibers. The last ones I used would drag badly--especially after sitting for a while. I think the fibers swell with oil over time and cause them to not be able to disengage. Change the oil, replace the fiber plates with OEM, and I bet you'll be good.

one more thing!

the arm that go's through the case cant even be disengaged with channel locks, i grabbed the lever with them to see if i could do it that way, and still a jam.. ill probably break it apart tonight for you guys though.

thanks so much!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now