Hard Clutch pull 02 426

I have an 02 426 and the clutch seems really hard to pull. I have had the cable off and lubed, as well as installing an easy pull clutch lever. That helped a bit but still nothing like my friends cr450. Do I just need to live with this or should I order and install a rekluse? Also has anyone here modified a 426 to have a remote hot start? is there a kit? I am just getting into racing MX after years of trail riding. My other option is to grab the 08 450. I know where to get one for under 6000 out the door. Anyone know any better deals on those? Thanks for any help out there.

What kind of shape is the clutch cable in? Is the outside kinda melted? That can cause it to be stiffer. The bike may also have heavy clutch springs installed.

Do I just need to live with this or should I order and install a rekluse? Also has anyone here modified a 426 to have a remote hot start?.

You should get a Rekluse, its one of the best mods you can do regardless of what kind of riding you do.

I've often thought about a remote hot start, but I don't use my hot start enough to justify the cost. I found that when my bike requires the hot start, it also needs a carb cleaning. Don't ask me why, but when I clean the carb, it starts fine without pulling the red knob.

Maybe some bikes are different, because my wifes bike won't start without the hot start once its been warmed up.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now