HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
tarmac_terrorist

bad choke on new 07?

3 posts in this topic

I went to start my 07 and went for the choke. I tried pulling the choke out but it will not hold open in the 'cold' position. It remains firmly in the warm position.

This is a brand new unridden bike. Any ideas as to why i cant open my choke?

Thanks

Share this post


Link to post
Share on other sites

I think if it were mine I would just take it off , to get a better look at it .most likley it just has a bit of corrotion or dirt in it making it stuck .take it apart and clean it .

Share this post


Link to post
Share on other sites
I think if it were mine I would just take it off , to get a better look at it .most likley it just has a bit of corrotion or dirt in it making it stuck .take it apart and clean it .

Thanks very much tweav. I spoke to a yamaha tech about this and he said much the same thing. He reckoned it was either internal carb corrosion or varnish from stale fuel. Im slightly miffed that this has happened. I'll try cleaning the part and swapping the fuel out for fresh and will add a fuel stabiliser.

Thanks for your time.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0