dirty coolant

i was filling up my coolant today ( yzf 400 99 ) and i noticed the coolant looked like there was dirt in it and the water was a black colour. still looked like water just a dark tinge to it. just had the head done and new gaskets 20 hours ago. any ideas on what could be causing this problem?

if there is dirt in there, it might of came from when you opened your cap and it fell in...

i was filling up my coolant today ( yzf 400 99 ) and i noticed the coolant looked like there was dirt in it and the water was a black colour. still looked like water just a dark tinge to it. just had the head done and new gaskets 20 hours ago. any ideas on what could be causing this problem?

Flush your cooling system and refill with new coolant. Ride the bike then check it again.

If you are running straight water, it's probably a sign that there's been some corrosion of the aluminum in the system.

Drain it and refill with a good corrosion inhibiting coolant.

if there is dirt in there, it might of came from when you opened your cap and it fell in...

flush it out and keep an eye on it....coolant should not be getting dirty

it could be a water pump seal or hoses that are disolving. which would be bad too.

i would pull the water pump cover and take a look. a new water pump seal is about $4.

the last thing you want is it going out on a ride. it drains all your coolant out the bottom weep hole and you never know it.

It sounds like straight water was put in at some point.

ive been running motul coolant and water wetter and it was not chewing water there for a bit but it is starting to use more water again. i top it up with straight water so thats mabye why its doing it. ill give it a flush and see how it goes. thanks.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now