Sign in to follow this  
Followers 0
Grae

450, hard to start and bacfiring..

7 posts in this topic

I`m having some trouble with my bike,05 yz450f. It`s a bit hard to start I have to kick it like 5- 20 times to get it to start when it`s cold, and if it stops when it is hot it`s almost impossible to start again. And it is popping and backfiring like crazy when I shut of the throttle. My main jet is 170, and pilot is 45. Don`t know where the clip is at the needle. The exhaust is a powerbomb header with a leo vinci silencer, twin air filter and hot stage cams. Hope someone can help me with this.. I`m a bit lost..

Share this post


Link to post
Share on other sites

More info needed...

Did this just start?

Has the carb been cleaned ever?

when was valves adj?

Jetting ...what is your altitude and temp?

popping after the bike is turned off may be a sympton of a exhaust valve sticking....Does it pop while running?

Share this post


Link to post
Share on other sites

1. Play in the hot start lever/cable (It will idle high and backfire on decel, then stall quite often)

2.Needle jet is gunked up and sticking(usually in this case it won't even start, but you might be getting close.)

3. Valves? I doubt it. My 03 valves were checked at 350 hours. Perfect. No exaggeration.

Share this post


Link to post
Share on other sites
More info needed...

Did this just start?

Has the carb been cleaned ever?

when was valves adj?

Jetting ...what is your altitude and temp?

popping after the bike is turned off may be a sympton of a exhaust valve sticking....Does it pop while running?

I just bought it couple weeks ago. It was fine when I rode it at his place, but this startet when I got it home.

I`ve taken the carb appart and it looks clean.

The engine was rebuilt a year ago from a bottom end crash, but the bike was put together just before I bought it. The rebuild was done at a shop so I think the valves is good, but maybe I`ll check it out.

Altitude is 800ft , and temp is about 50-65 deg.

Thanks.

Share this post


Link to post
Share on other sites

Seems a little rich for 800ft...read the top 450 Jetting guide thread

Have you adjusted the fuel screw?

Is the Hotstart working properly or sticking in the carb?

Share this post


Link to post
Share on other sites
Seems a little rich for 800ft...read the top 450 Jetting guide thread

Have you adjusted the fuel screw?

Is the Hotstart working properly or sticking in the carb?

I have tried from 1 1/2-3 turns out on the fuel screw.

To me it looks like the hot start works.

I`ll try a 42 pilot and see if that works? Or try to change the main aswell?

I`ll read the Jetting tread and see if I can figure something out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0