XR650L Big Bog Problem

I replaced the springs on my XRL and had to remove the air box to get the rear spring replaced. After putting everything back together I now have a really bad bog off idol but once I get going in it runs fine. The bog is only just off idol so I am thinking I have a clogged pilot jet.

I will be digging into this problem tonight and wanted to see if anyone had any other ideas of what I may have missed when putting the air box back on.

I replaced the springs on my XRL and had to remove the air box to get the rear spring replaced. After putting everything back together I now have a really bad bog off idol but once I get going in it runs fine. The bog is only just off idol so I am thinking I have a clogged pilot jet.

I will be digging into this problem tonight and wanted to see if anyone had any other ideas of what I may have missed when putting the air box back on.

i would say something got loose and went into the carb and pluggged the pilot circuit someway.

you post i post twice LOL

WHITE thats one of those damn gremlins getting in when you had it apart, they just chap my azz. Id say maybe you need to take the carb off and clean it prolly. SUCKS i know there not easy like a MX bike where you can take the subframe off in 10 mins and have a clear shot to the carb.

check if you are getting a air leak around the carb spray some wd-40

with the bike running around the clamps you may have the carb cocked

a little sideways

Thanks guys. I am sure it is something simple. Just have to find it.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now