XRL - Left Blinker Quit Workin....

.

.

Right one is ok...just the left.

I have 4 days left on my 1 year warranty...'07 XRL.

Is this something I could fix myself, is it easy?

Or should I hound the local, expensive dealer (bought the bike in Phx on the cheap, 150 miles away).

BTW, I have aftermarket handlebars...does that matter?

OK assuming you checked the bulb.. If you have a dmm(volt meter) put it on and look for it to go from about 02 to OL (in OHMS )as the blink happens. If this fails you could disconnect the closest connection to the switch and do the same check. this will tell you if the problem is in the switch or maybe the wiring from the switch to the light has been damaged.. shorted etc... It really shouldn't be before the switch so this should solve the problem. If you get no deflection on your meter.. its the switch..

You could also do this with a "test light" that works at 12 volts and look for blinks.

Check all wire connections to and from the turn signal in question...

.

.

Is that a difficult thing to do?

Gotta crack the case on the blinker assembly I presume...

Bump for some love....

Looks like the blinker assembly just unscrews....

Think I can open it up w/o taking off grip/handlebars?

Can the blinker light just be picked up at AutoZone...or do I need something special?

My left blinker craps out form time to time, reason handle bar sunk in the mud beyond the blinker switch assm. I just haven't spent the time to take it apart and really clean it. I just flick the switch a bunch of times and it works.

This is one thing that it could be but check the other stuff previously mentioned.

yeah you need to take the cover off and prolly its only the bulb and autozone should carry them.

My left blinker craps out form time to time, reason handle bar sunk in the mud beyond the blinker switch assm. I just haven't spent the time to take it apart and really clean it. I just flick the switch a bunch of times and it works.

This is one thing that it could be but check the other stuff previously mentioned.

mine does this too. its a bad switch from filling the bars with foam:foul:

mine does this too. its a bad switch from filling the bars with foam:foul:

It kind of sucks when I go to take a left turn and as I realize the blinker isn't blink the car behind me is up me arse.

or

could it be from riding all those miles of trails with the blinker going...you know that guy who always has a blinker on in the middle of the woods.

ya a little spooky at times.

the signal guy in the woods rules!!!!

Pretty sure it's the switch (and not the bulb) since the back left blinker no workie either...

I'm just afraid of opening the blinker assembly and having 6 springs, 4 gears and a cotter pin all jump out and over the floor at once.

i wouldnt worry about that, just pop it off!

You know, I usually do that kinda stuff on an old terrycloth towel.

Does wonders for not letting little parts get away.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now