HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
jeanluconze

why does my 650L do this?

13 posts in this topic

after completely warmed up, the shifting gets clunky, throttle looses its snap, bike just feels less "tuned in". For the first 15 minutes or so, it's great. Shifts smooth, throttle is snappy, bike sounds great. What could this be?

Share this post


Link to post
Share on other sites

sounds like more than one problem.. have you cleaned the air filter recently? a dirty filter will throw things off once warmed up. have you changed the oil recently or not? as Denn10 said a little more info is needed...

Share this post


Link to post
Share on other sites

Some more information:

This has happened since day one. Changed the oil 400 miles ago, 10-40w HP4. Uni filter is clean and properly oiled. 1k miles on it. Never checked the downtube screen.

I'm wondering if the fuel mixture screw is jacked somehow.... when turned in all the way down, should it seat against the carb or is there still a gap? Mine doesn't seat all the way down. I have it 2.5 turns out from where it stops and it's really hard to turn (that could be because I ground the tab off, though).

At start up, i use the choke half way for maybe 5 seconds. After warm it starts up fine, sometimes needs a little throttle but not much. Temp dipstick shows 230 to 250 at fully warmed, riding around streets. The oil "feels" too thin, like it's not sticking to the gears. It doesn't burn oil. No smoke on accel /decel/idle, very little popping.

Share this post


Link to post
Share on other sites

problem from the start HMMM check this out about your fuel screw and see what that does for ya, it may not be the perfect jetting for your area as the dave's mods recomendations are not perfect for everyone, im using 58/162

http://www.thumpertalk.com/forum/showthread.php?t=327405

Your clunking on shift is prolly from the oil, i know mine does a tad bit but from my street bike i switched from HP4 to Mobil1 4T full synthetic and it helped alot, clunking on my cbr600rr is a common thing though. Havent seen alot with the Ls and complaints on that though.

Share this post


Link to post
Share on other sites

yeah i was told by XRs only use the 20/50 all year for us in CA and LV fools too. GOOD EYE martin

Share this post


Link to post
Share on other sites
i use the honda oil 20w-50 in summer. this may help.

I already bought some GN-4 20/50 for the next change. I'll probably go with synthetic after that. As for the fuel screw, is it normal that I can turn it 1 full turn either way from 2.5 turns out and not notice a difference in idle speed?

Share this post


Link to post
Share on other sites
I already bought some GN-4 20/50 for the next change. I'll probably go with synthetic after that. As for the fuel screw, is it normal that I can turn it 1 full turn either way from 2.5 turns out and not notice a difference in idle speed?

my fcr does this too. this usually means the pilot is too big. or should i say that if you can turn it all the way in with no change, that means pilot is to big.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0