2006wr450f

What did you do to your WR today?

4,495 posts in this topic

That is the "Restyle" Cycra front fender for the YZ 2strokes. The hole pattern is perfect for all WR's prior to 2012.

Share this post


Link to post
Share on other sites

Picked this up today on the WR. It was good for 13th Overall B and 3rd Place B 40+ Long course. 85 ground miles. image.jpg

Not too bad not having rode since Summer. Pretty rough trail. I had my hands full just trying to finish.

2 people like this

Share this post


Link to post
Share on other sites

still2smokin, I hope it's pop-riveted on then, as I don't know how else it will stay permanently attached. :confused:

Share this post


Link to post
Share on other sites

I used the same double back tape that the gopro mounts use. I know, I know , double back tape sounds chessy but

a 1 1/2 X 2 inch piece holds my gopro to my helmet extremely well even with the camera getting caught on tree branches

and trying rip my head off .....it hasnt ever budged yet .

I covered the whole mountiing bracket for the light with that tape and cut little 1/4 inch strips for the wiring loom.

Seems damn strong to me, and hey if it starts to loosen I will throw a couple rivets in it .

Share this post


Link to post
Share on other sites

I ordered a new White Clark 10.6 litre tank, a white ufo plastic kit, and dropped off all the parts at the Powdercoater. Ordering wheels, Stator, linkage bearrings, and a Vapor Speedo tomorrow. :D It's like christmas again!

Share this post


Link to post
Share on other sites

Just stared and wished I would have went out and enjoyed the beautiful 75 degree weather. Working on weekends sucks :cry:

2013-02-02wr.jpg

Share this post


Link to post
Share on other sites

Went and bought a new battery to replace the one I toasted after leaving the power switch on for who knows how long.

Share this post


Link to post
Share on other sites

Rode it yesterday after nearly 2 months of no riding ....

DSCN1242_zps79bfa824.jpg

Didn't get far.... still having same issue. This tiime I had my buddys carb in it aswell as a fresh plug.

Still just died out after only a very short time. AAARRGGHH !!!

Yanked the plug, it looks odd .... it was in for maybe 10 min ... its a split fire I borrowed from a buddy.

IMG2848_zpsa304759b.jpg

So its not carb related, that leaves mechanical or electrical....

Electrical -- I still have to test the stator, which requires running the bike up to 5000 rpm with no gas tank (safely) .

Needless to say a PITA.

Mechanical---

IMG2868_zps41784a1a.jpg

Valves checked exactley the same as last year , all passed with in range .

I am thinking about a compression test but I find nothing in the manual about it other

than tearing it apart and physically measuring piston, cylinder , valves etc....

Uugghh........I am pretty sure its electrical and that means stator, CDI or harness issue.

Nothing looks suspect in the harness or connectors that I can see so now its time to check the stator

and if thats fine I am buying the Dynatek CDI.

I just wanna ride damn it !

Edited by still2smokin

Share this post


Link to post
Share on other sites

Rode it yesterday after nearly 2 months of no riding ....

DSCN1242_zps79bfa824.jpg

Didn't get far.... still having same issue. This tiime I had my buddys carb in it aswell as a fresh plug.

Still just died out after only a very short time. AAARRGGHH !!!

Yanked the plug, it looks odd .... it was in for maybe 10 min ... its a split fire I borrowed from a buddy.

IMG2848_zpsa304759b.jpg

So its not carb related, that leaves mechanical or electrical....

Electrical -- I still have to test the stator, which requires running the bike up to 5000 rpm with no gas tank (safely) .

Needless to say a PITA.

Mechanical---

Check the electrical values on your coil. It sounds like it's doing the same thing my 04 did a few years back.

Valves checked exactley the same as last year , all passed with in range .

I am thinking about a compression test but I find nothing in the manual about it other

than tearing it apart and physically measuring piston, cylinder , valves etc....

Uugghh........I am pretty sure its electrical and that means stator, CDI or harness issue.

Nothing looks suspect in the harness or connectors that I can see so now its time to check the stator

and if thats fine I am buying the Dynatek CDI.

I just wanna ride damn it !

Share this post


Link to post
Share on other sites

Check the electrical values on your coil. It sounds like it's doing the same thing my 04 did a few years back.

Thats the first thing I replaced followed by a needed voltage regulator/rectifier.

So I started do the tests in the manual yesturday and the (resistance) pick up coil measured strange...

Then the bike wouldn't even run long enough to do the voltage tests ... so today I ordered

a Ricky Stator DC setup, hopefully its here by friday .

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


  • Similar Content

    • By nate9521
      So apparently some mx fcr carbs have removable valve seats and some dont. I didnt know this and just thought mine was really stuck in there so i drilled it out. Was going to replace it anyway. But it turns out that i have the model that is not suppose to have the valve seat removed. or so i think. Is anyone aware of this difference between the same carb. Do you know where i can get another valve seat? its off a 2003 yz450f
    • By Hammerthrottle
      Hey all, recently getting into motocross again and bought a used bike from a kid who lacked on the maintenance side of things for the bike. What I have found / believe is happening is oil is leaking out of the cylinder head breather tube. Before going on my first ride with the bike I had a respectable amount of oil right in the middle of the checkered oil marks on the dip sticks. However after about 5 hours riding I checked the oil to find that it was barely even on the dip stick. I know there has been oil leaking out of the breather but could have been caused because an overflow on the oil change from the kid. I mean the bike is 8 years old maybe it is time for some top end work. On that note would a person change out the piston regardless of condition along with the rings? Is it possible the rings are just not positioned right? I would definitely do the valves while I have the bike open anyways.
       
      Any info would be greatly appreciated I just find it odd that it took 5 hours to drain, reading through other posts some guys were having puddles of oil after 20 minuets of running time.
       
    • By Eduardo Stevenson
      Hi guys , how you doing , i got a problem with a YZ450F 2009 , Carb is missing, i was checking on ebay to get one new or used, but i found one for a YZ250F 2009, it look the same as the 450 , but obviously jets change, i wanna know if this carb is going to fit MY 450 , THANKS , if somebody knows something about this. 
    • By TheAirborneCheese
      I live in northwest Virginia (Charlottesville area)  about an hour south of DC, I am not aware of any tracks in the area that are either public (or private but allow people to ride with permission).  Does anyone know of any good tracks in my area?
      - Airborne