HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
neevothespaniel

Specifics needed for installing hour meter

6 posts in this topic

I was after some info on installing an hour meter on my YZ450F (2005). I want to make it as discreet as possible and have 2 questions:

1. Where is the best place to ground (earth) the hour meter. There is a metal loop on the end, is there a bolt that I can undo to bolt the earth to the frame?

2. I am going to wire it into the kill switch, could someone confirm that I splice the wire into the black wire with the grey stripe through it?

Pictures would be awesome to help me picture it. For those that might need it the hour meter is a motominder.

Thanks in advance.

Share this post


Link to post
Share on other sites

My hour meter is made by Sendec so it may be different from yours. Mine has no ground wire. There is only one wire and it wraps around the sparkplug cap a few times. I mounted mine in the crossbar pad. What year is your bike?

Share this post


Link to post
Share on other sites

I just went ahead and mounted it. I grounded it on the mount for the radiator and hooked it into the kill switch wire with the grey line on it.

Fired the bike up and the thing light up with 0.0 hours on it. I ran it for a couple of minutes as per the instructions but I assume it didn't run for long enough to log any time.

Does this sound right to anyone?

Share this post


Link to post
Share on other sites

Run the bike for at least 6 minutes (.10 hours) and you should know if its working. It has power at least. Thats a good start

Share this post


Link to post
Share on other sites
I just went ahead and mounted it. I grounded it on the mount for the radiator and hooked it into the kill switch wire with the grey line on it.

Fired the bike up and the thing light up with 0.0 hours on it. I ran it for a couple of minutes as per the instructions but I assume it didn't run for long enough to log any time.

Does this sound right to anyone?

Yeah thats right, is it a motominder brand?

I have one and at first it wont remember the date like its supposed to but once you have an hour or two on it the date it was installed magically appears and is 100% accurate.

Share this post


Link to post
Share on other sites
Yeah thats right, is it a motominder brand?

I have one and at first it wont remember the date like its supposed to but once you have an hour or two on it the date it was installed magically appears and is 100% accurate.

Yep its a motominder. Sounds like I lucked out with the install. Looks like a sweet unit.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0