HEADS UP!!!

Site upgrade in progress... Core site functions are working, but some non-critical features/functions will be temporarily unavailable while we work to restore them over the next couple of weeks.

Please post any bugs you encounter, but before you do, check to see if it's already listed.

Thanks for your patience while we work to improve the community.

Sign in to follow this  
Followers 0
GseMech

Smog Removed Now Idle Hangs Up

4 posts in this topic

Just finished removing the smog equipment from my '04 650L using the kit from Baja Designs. I followed the sequence laid out on the XRs Only website as it was the same as mine. I now find that the idle hangs up momentarily before settling down. Before the smog removal this was never a problem.The bike is otherwise all stock. Any suggestions?:thumbsup::busted::thumbsup:

Share this post


Link to post
Share on other sites

On my 650R I just richened the idle mixture, it's dead stable now and no decel popping. On my 650L years back I had rejetted and removed the smog stuff at the same time it was fine.

Share this post


Link to post
Share on other sites

maybe you should check your throttle cables. maybe they were disturbed somehow during the job.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0