Sign in to follow this  
Followers 0
jct9841

XR650L Engine stalling/dying because...?

6 posts in this topic

Hello all,

Took the bike out for a 50 mile ride last weekend. The engine died a couple of times when downshifting for a stop sign & pulling in the clutch. Started OK with the starter.

Also when cruising at highway speeds and suddenly backing off on the throttle and pulling in the clutch the engine died. Started by popping the clutch.

Any ideas?

Thanks in advance.

JT

Share this post


Link to post
Share on other sites
try bumping up the idle alittle bit

Yah bump up the idle a little bit and perhaps turn out the pilot screw a little bit.

Share this post


Link to post
Share on other sites

Mine does that right after installing a freshly oiled UNI filter. After a little while it clears up.

Share this post


Link to post
Share on other sites
Mine does that right after installing a freshly oiled UNI filter. After a little while it clears up.

over oiling?

Share this post


Link to post
Share on other sites

Did you put on a new gas cap or vent tube. Mine does the same thing and think it may be a vacuum problem. If you don't have a new cap or tube then maybe I am barking up the wrong tree.

I can tell you it is not the CDI, I already replaced it and no fix. Next will be the coil and plug.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0